tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tek1 <t...@pobox.com>
Subject Re: Suspected Content-Length bug in SSL adapter, Tomcat 4.0.4.
Date Tue, 10 Sep 2002 13:14:51 GMT
not sure if the problems are connected, but i ran into a bug with filters 
not setting the content-length of the response correctly.  please check the 
archives for my post entitled "RE: anyone using filter to set content 
length of response?".

it would require digging into the tomcat code, but i wonder if the 
connectors make use of filters and the problems are connected?

i ran my application in jetty and the response's content length was set 
correctly.

can you try running your application in tomcat4.1.10 (latest stable) or 
another servlet container (i.e. jetty, jrun, etc.) to see if the problem 
still exists?

my application was dealing with a mobile client, which cannot determine for 
itself what the incoming content-length is and thus requires the 
content-length to be explicitly set on the server.  although this problem 
existed on the mobile client, it did not happen when i accessed the 
application using netscape4.79, which leads me to believe that some 
browsers are capable of automatically determining the content-length, even 
if it is not set explicitly on the server...




At 18:45 02/09/10 +0930, you wrote:
>Hi,
>
>I have spent hours trying to figure this out and have searched the bug
>database and the mailing list archives, and have not had any luck, so
>I am posting it here.
>
>The story:
>
>* I am building a web application using tomcat and struts.
>* This application is a simple, four-form system, with one form
>   following another.  Forms are JSPs.
>* Everything works using an HTTP connector.
>* Everything works using an HTTPS connector and lynx or IE.
>
>Now the story gets strange.  When I use mozilla or netscape for linux,
>or netscape for NT, the first two forms function correctly but the
>third does not.  Viewing the page source shows that the browser is
>receiving the HTML correctly, but is not displaying it.  Netscape 4.x
>on NT says 'Connection reset by peer.'  There are no errors in any of
>the tomcat logs.
>
>If I try a GET request for the third form (ie. type its URL into the
>address bar of a browser) then it is displayed correctly.  It is only
>when I try to get it by submitting another form that things go wrong.
>This form has its method set to POST.
>
>This third form does not involve any struts actions or actionforms.
>It is a JSP, and the form on the previous page has its 'action'
>property set to the JSP URL, not an action.
>
>This problem persists even if I cut the third form down to this:
>
>HelloHello.
>My conclusion is that the SSL connector is probably setting the
>Content-Length header incorrectly, causing browsers that look at that
>header to expect more content than is actually being sent, hence the
>'Connection reset by peer' message despite the HTML being received
>correctly.
>
>Has anyone come across this before?  Is this a known bug?  Is there a
>workaround?
>
>If you wish to look at the site yourself, you may be able to get to it
>using this URL:
>
>https://barney.development.adelaide.edu.au:8443/epayment/
>
>A valid customer number and invoice number are:
>
>Cust No: 9999999800
>Invoice No: FINA802792
>
>You may not be able to access this URL; I am not sure about the
>firewall configuration.
>
>TIA for any help.
>
>Tom
>--
>Tom Cook
>Information Technology Services, The University of Adelaide
>
>"The secret of creativity is knowing how to hide your sources."
>         - Albert Einstein
>
>Get my GPG public key: 
>https://pinky.its.adelaide.edu.au/~tkcook/tom.cook-at-adelaide.edu.au


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message