tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Funk <funk...@joedog.org>
Subject Re: Startup-Problems: Tomcat 4.0.4 binary on Linux w/J2SDK 1.3.1
Date Sun, 01 Sep 2002 13:58:51 GMT
1) A java process in linux shows up many times with ps or top (because 
of multiple threads)
2) See logs/catalina.out for an error message. There is propably a 
misconfig in server.xml or another run time error the tomcat cannot 
recover from. In any case the logs/catalina.out captures stdout/stderr.


Kilian wrote:
> Hi all,
> 
> I am trying to run the binary distribution of Tomcat 4.0.4 with the Sun 
> j2sdk 1.3.1_04 on Linux 2.4.16. $JAVA_HOME and $CATALINA_HOME are set, 
> port 8080 is free but when I execute $CATALINA_HOME/bin/startup.sh, I get:
> 
>  Using CATALINA_BASE:   /usr/local/jakarta-tomcat-4.0.4
>  Using CATALINA_HOME:   /usr/local/jakarta-tomcat-4.0.4
>  Using CATALINA_TMPDIR: /usr/local/jakarta-tomcat-4.0.4/temp
>  Using JAVA_HOME:       /usr/lib/java
> 
> The shell returns immediately, and for a very short time, `ps x` shows 8 
> java processes running, like:
> 
>  /usr/lib/jdk1.3.1_04/bin/i386/native_threads/java \
>  -Djava.endorsed.dirs=/usr/local/jakarta-tomcat-4.0.4/bin: \
>  /usr/local/jakarta-tomcat-4.0.4/common/lib -classpath \
>  /usr/lib/java/lib/tools.jar:/usr/loca...
> 
> but these disappear after a few seconds. I get no error, nothing gets 
> logged into logs/catalina.out and no java or tomcat process is running, 
> nothing on Port 8080.
> 
> What am I missing? Has anyone experienced similar problems? How can I 
> track down this further? I would be grateful for any hint... Thanks very 
> much!
> 
> Greetings,
> Kilian



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message