tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Cox, Charlie" <c...@cincom.com>
Subject RE: Debugging class loading
Date Tue, 10 Sep 2002 11:49:10 GMT
before you go hacking with your own classloader, have you reviewed the
classloader doc? What kind of problems are you having? 

Only classes in each web application are loaded by the web app's
classloader. If you have classes in \common\lib or \tomcat\lib, they are
loaded by StandardClassLoader.

Charlie

> -----Original Message-----
> From: Michael Petres [mailto:michaelp@innovobjx.com]
> Sent: Sunday, September 08, 2002 9:32 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Debugging class loading
> 
> 
> Folks,
> 
> I have run into some problems with class loading in my 
> servlet... I would like
> to debug the loading of ALL classes by tomcat. One option I 
> was thinking of
> was to (for debugging) add a the following under the <context> tag :
> 
> 
> <Loader className="org.apache.catalina.loader.WebappLoader" 
> delegate="false"
> reloadable="false" checkInterval="15" debug="99"
> 
> cloaderClass="my.custom.CustomClassLoader"/>
> 
> where CustomClassLoader would extend WebappClassLoader. Is 
> this feasible ?
> Perhaps there is a better option....
> 
> I would appreciate any ideas as I am stuck with this problem...
> 
> Thanx,
> Michael Petres
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> InnovObjX Corp.
> Web: www.innovobjx.com
> Tel: 905-729-2235 x3
> Fax: 905-729-2235
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> 
> 

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message