tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Stokes" <Chr...@BassSoftware.com>
Subject Tomcat just stops
Date Thu, 05 Sep 2002 02:03:44 GMT
I am running Tomcat 4.0.3 with latest mod_jk and apache 1.3.22 on 2 servers running RHLinux
7.3 and 7.2 respectively

On both of these machines I regularly (read a 5 or more times a day) have to start tomcat
again as it's processes have gone. There are no errors in any tomcat logfiles.

This is the error from mod_jk.log - which appears to be just symptomatic of the lack of any
tomcat process.

[Thu Sep 05 09:49:57 2002]  [jk_connect.c (151)]: jk_open_socket, connect() failed errno =
111
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (599)]: In jk_endpoint_t::ajp_connect_to_endpoint,
failed errno = 111
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (844)]: Error connecting to the Tomcat process.
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (1153)]: In jk_endpoint_t::service, ajp_send_request
failed in send loop 0
[Thu Sep 05 09:49:57 2002]  [jk_connect.c (151)]: jk_open_socket, connect() failed errno =
111
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (599)]: In jk_endpoint_t::ajp_connect_to_endpoint,
failed errno = 111
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (844)]: Error connecting to the Tomcat process.
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (1153)]: In jk_endpoint_t::service, ajp_send_request
failed in send loop 1
[Thu Sep 05 09:49:57 2002]  [jk_connect.c (151)]: jk_open_socket, connect() failed errno =
111
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (599)]: In jk_endpoint_t::ajp_connect_to_endpoint,
failed errno = 111
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (844)]: Error connecting to the Tomcat process.
[Thu Sep 05 09:49:57 2002]  [jk_ajp_common.c (1153)]: In jk_endpoint_t::service, ajp_send_request
failed in send loop 2

All I can do is stop apache and then start tomcat and start apache.
I have no contexts defined in server.xml, I just allow tomcat to auto generate my contexts
when it starts. This works fine and gives no errors.
I am using IBMJavaSDK 1.3.0-10.

Any help greatly appreciated.

Chris Stokes
Senior Systems Consultant
Bass Software Pty Ltd
ChrisS@BassSoftware.com
        ____                ____         __ _
       | __ )  __ _ ___ ___/ ___|  ___  / _| |___      ____ _ _ __ ___
       |  _ \ / _` / __/ __\___ \ / _ \| |_| __\ \ /\ / / _` | '__/ _ \
       | |_) | (_| \__ \__ \___) | (_) |  _| |_ \ V  V / (_| | | |  __/
       |____/ \__,_|___/___/____/ \___/|_|  \__| \_/\_/ \__,_|_|  \___|


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message