tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Habibak haAlbek <habiba...@yahoo.com>
Subject RE: Apache 1.3.26 to Tomcat 4.0.4 PROBLEM with mod-Jk on solaris
Date Thu, 12 Sep 2002 15:19:59 GMT

yes. It is the name of a machine. I changed the name from localhost to the machine name even
tho tomcat and apache are on the same machine. still a problem.
En tous cas Merci Monsieur!
 Vincent.Gaboriau@answare.fr wrote:First


must be :

debug="0">

In your workers.properties, you have:
worker.ajp13.host=ebusiness.corp.teradyne.com

Is "ebusiness.corp.teradyne.com" knowned? "ebusiness.corp.teradyne.com" must
be a machine name.

You must specify the host in the workers.properties when Tomcat is installed
in a different machine than Apache. If it's not the case you can let that as
localhost.

-----Message d'origine-----
De : Habibak haAlbek [mailto:habibak73@yahoo.com]
Envoye : jeudi 12 septembre 2002 16:57
A : tomcat-user@jakarta.apache.org
Objet : Apache 1.3.26 to Tomcat 4.0.4 PROBLEM with mod-Jk on solaris



Still hangs. Apache alone works fine. TomCat alone works fine. something is
wrong with the connector configuration. here's what I have:

1- Server.xml :



- 






- 





port="8080" minProcessors="5" maxProcessors="75" enableLookups="true"
redirectPort="8443" acceptCount="10" debug="0" connectionTimeout="60000" />







minProcessors="5" maxProcessors="75" acceptCount="10" debug="10" />







- 



prefix="catalina_log." suffix=".txt" timestamp="true" />







- unpackWARs="true">


append="true" forwardAll="false" />

directory="logs" prefix="localhost_access_log." suffix=".txt"
pattern="common" />



prefix="localhost_log." suffix=".txt" timestamp="true" />









+ crossContext="true">

prefix="localhost_examples_log." suffix=".txt" timestamp="true" />

home="com.wombat.empl.EmployeeRecordHome"
remote="com.wombat.empl.EmployeeRecord" />









-->f(clean);




override="false" />

type="javax.sql.DataSource" />

- 

- 


user

sa




- 


password






- 


driverClassName

org.hsql.jdbcDriver




- 


driverName

jdbc:HypersonicSQL:database






/>

- 

- 


mail.smtp.host

localhost
















- 



- name="Apache" debug="0">



prefix="apache_log." suffix=".txt" timestamp="true" />













2. workers.properties looks like this:
#
# workers.properties
#
worker.list=ajp12, ajp13
workers.tomcat_home=/export/home/eapps/apacheTomCat/jakarta-tomcat-4.0.4
workers.java_home=/usr/java1.2
ps=/
worker.ajp13.port=8009
worker.ajp13.host=ebusiness.corp.teradyne.com
worker.ajp13.type=ajp13
#
# END workers.properties
#

3. JDK version is 1.2.2_05a

4. httpd.conf contains the following lines
LoadModule jk_module libexec/mod_jk.so (I even downloaded another so than
then the one I have compiled)
AddModule mod_jk.c
JkWorkersFile /apache-dir/conf/workers.properties
JkLogFile /apache-dir/logs/mod_jk.log
JkLogLevel debug
JkMount /*.jsp ajp13
JkMount /servlet/* ajp13

it can not be simpler than that configuration wise, at this point It is
becoming frustrating not having a clue what's going on! Thanks for your
help!



---------------------------------
Do you Yahoo!?
Yahoo! News - Today's headlines


--
To unsubscribe, e-mail: 
For additional commands, e-mail: 



---------------------------------
Do you Yahoo!?
Yahoo! News - Today's headlines
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message