tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yaogeng Cheng <ych...@neiglobal.com>
Subject RE: installing and running tomcat 4.1 on linux
Date Mon, 23 Sep 2002 18:16:33 GMT
I did not repost these questions, but it is odd that they are got posted
again.

I set up the CATALINA_HOME and JAVA_HOME in /etc/profile. I used echo
$CATALINA_HOME and echo $JAVA_HOME to make sure they are set and when I
start up the tomcat, the following message comes up
Using CATALINA_BASE:   /usr/local/jakarta-tomcat-4.0.4
Using CATALINA_HOME:   /usr/local/jakarta-tomcat-4.0.4
Using CATALINA_TMPDIR: /usr/local/jakarta-tomcat-4.0.4/temp
Using JAVA_HOME:       /usr/jdk1.3.1
Using classpath:
/usr/jdk1.3.1/lib/tools.jar:/usr/local/jakarta-tomcat-4.0.4/bin/bootstrap.ja
r

It still does not work. The same error message. I wander if it is because my
Linux machine(6.2.4) doesn't work with Tomcat4.x. I installed tomcat 3.3.1,
and everything works fine.

Thanks,

Yaogeng

-----Original Message-----
From: Turner, John [mailto:JTurner@AAS.com] 
Sent: Monday, September 23, 2002 7:30 AM
To: 'Tomcat Users List'
Subject: RE: installing and running tomcat 4.1 on linux



Are these repeat postings somehow?  I thought I replied to this last week.

I don't have any suggestions...installing and running Tomcat from binary is
a fairly straight-forward 5 step process.  I don't modify my startup scripts
at all...I set my environment variables in /etc/profile or in a user
directory, depending on the scenario.

Are you sure that CATALINA_HOME and JAVA_HOME are actually set throughout
the entire startup process?  How do you know?

John


> -----Original Message-----
> From: Yaogeng Cheng [mailto:ycheng@neiglobal.com]
> Sent: Monday, September 23, 2002 10:16 AM
> To: 'Tomcat Users List'
> Subject: RE: installing and running tomcat 4.1 on linux
> 
> 
> I have JDK1.3.1 installed. I used binary install just as your
> instruction
> outlined. In catalina.sh, I include the following lines.
> export 
> PATH="/sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin:/usr/jdk1.3.1/bin"
> export JAVA_HOME=/usr/jdk1.3.1
> export CATALINA_HOME=/usr/local/jakarta-tomcat-4.0.4
> 
> My server is a VA linux machine version 6.2.4.
> 
> Thanks a lot!
> 
> Yaogeng
> 
> -----Original Message-----
> From: Turner, John [mailto:JTurner@AAS.com]
> Sent: Friday, September 20, 2002 11:04 AM
> To: 'Tomcat Users List'
> Subject: RE: installing and running tomcat 4.1 on linux
> 
> 
> 
> Something has to be messed up.  Installing Tomcat stand-alone
> is a simple 5
> step process:
> 
> - download Tomcat
> - unpack Tomcat
> - set CATALINA_HOME
> - start Tomcat
> - verify examples
> 
> You installed the JDK?  You have JAVA_HOME set?  Did you use
> an RPM or the
> binary install?  Did you build from source?
> 
> John
> 
> > -----Original Message-----
> > From: Yaogeng Cheng [mailto:ycheng@neiglobal.com]
> > Sent: Friday, September 20, 2002 2:00 PM
> > To: 'Tomcat Users List'
> > Subject: RE: installing and running tomcat 4.1 on linux
> > 
> > 
> > I should have said that no jsp works. However, some executalbes such 
> > like ErrorPage will call a html first, so it work, but when I
> > click submit, it
> > throws the same error message.
> > 
> > Thanks
> > 
> > Yaogeng
> > 
> > -----Original Message-----
> > From: Turner, John [mailto:JTurner@AAS.com]
> > Sent: Friday, September 20, 2002 10:39 AM
> > To: 'Tomcat Users List'
> > Subject: RE: installing and running tomcat 4.1 on linux
> > 
> > 
> > 
> > "most" JSPs do not work?  Some work and some don't?
> > 
> > John
> > 
> > 
> > > -----Original Message-----
> > > From: Yaogeng Cheng [mailto:ycheng@neiglobal.com]
> > > Sent: Friday, September 20, 2002 1:22 PM
> > > To: 'Tomcat Users List'
> > > Subject: RE: installing and running tomcat 4.1 on linux
> > > 
> > > 
> > > Hi, John:
> > > 
> > > I tried your howto instructions, and it seems a very good
> > > instruction. I installed tomcat4.0.4 without installing 
> > > apache1.3.26. I tried http://MyServer:8080/examples, the 
> page comes
> > > up. However, most jsp Executables (Numberguess, Date,
> Snoop ) does
> > > not work. All the servlets work
> > > though? Any ideas why? The error message is attached!
> > > 
> > > Thanks a lot!
> > > 
> > > Yaogeng
> 
> --
> To unsubscribe, e-mail: 
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail: 
> <mailto:tomcat-user-help@jakarta.apache.org>
> 
> --
> To unsubscribe, e-mail:   
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

tsdok

--
To unsubscribe, e-mail: <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message