tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steltner, Jörn HTC/DE/ESS" <>
Subject Appache v2.0.40 + Tomcat 4.1.x + Connectors
Date Fri, 27 Sep 2002 07:58:30 GMT

I installed the Apache and Tomcat from source. Both are running well. I
compiled the jk2 connectors and made the configuration. Apache is loading
the module, but couldn't find the jk-worker. The Tomcat installation gets an
error in the Log-File. It seems that Apache can no find the Tomcat

I need some help.


Part I: mod_jk.log

[Fri Sep 27 09:35:26 2002]  [jk_uri_worker_map.c (477)]: Attempting to map
URI '/examples/jsp/source.jsp'
[Fri Sep 27 09:35:26 2002]  [jk_uri_worker_map.c (558)]:
jk_uri_worker_map_t::map_uri_to_worker, Found a suffix match ajp13 -> *.jsp
[Fri Sep 27 09:35:26 2002]  [mod_jk.c (1277)]: Into handler r->proxyreq=0
r->handler=jakarta-servlet r->notes=135575144 worker=ajp13
[Fri Sep 27 09:35:26 2002]  [jk_worker.c (132)]: Into wc_get_worker_for_name
[Fri Sep 27 09:35:26 2002]  [jk_worker.c (136)]: wc_get_worker_for_name,
done did not found a worker

Part II: catalina.out

Starting service Tomcat-Standalone
Apache Tomcat/4.1.10
[ERROR] JkMain - -No class name for request  request 
[INFO] JkMain - -APR not loaded, disabling jni components: /opt/jakarta/lib/ cannot open
shared object file: No such file or directory
[INFO] ChannelSocket - -JK2: ajp13 listening on tcp port 8009
[INFO] ChannelUn - -No file, disabling unix channel
[INFO] JkMain - -Jk running ID=0 time=1/75

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message