tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thad Humphries <t...@mindwrap.com>
Subject Tomcat 4.1.12 doesn't use my applications WEB-INF/lib
Date Mon, 30 Sep 2002 19:30:30 GMT
I have an application written well over a year ago that uses Xerces 1.4
and Xalan 1.2 for its XML parser and XSL translations.  I know that this
will have to be updated someday but because of short resources and no
few customer complexities, we can't at this time.

The application runs fine under Tomcat 3.2.x, Tomcat 4.0.x, and WebLogic
6.1.  However, the older XML causes problems with Tomcat 4.1.  Here's
one case (for example):  Tomcat 4.1 seems to be using the
org/xml/sax/InputSource.class from
jakarta-tomcat-4.1.12/common/endorsed/xmlParserAPIs.jar vs.
<myapp>/WEB-INF/lib/xerces.jar's org/xml/sax/InputSource.class (efforts
to create a InputSource to create a Xalan 1.2
org.apache.xalan.xslt.XSLTInputSource error with "Incompatible object
argument for function call").

We are using Xerces 2 for all newer applications and would like to move
up to Tomcat 4.1.  How can I run this older application in Tomcat 4.1? 
I'd rather not have to swap back and forth or run a 2d Tomcat.
-- 
------------------------------------------------------------------------
Thad Humphries              "...no religious test shall ever be required
Web Development Manager      as a qualification to any office or public
Phone: 540/675-3015, x225    trust under the United States." -Article VI


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message