tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin, Rick" <RGa...@vidyah.com>
Subject RE: Tomcat 4.1 Installation
Date Mon, 23 Sep 2002 13:29:55 GMT
I've been having this same issue since I upgraded from 4.0.4 to 4.1.10.  It
seems that the classloader isn't functioning correctly for me. I had to put
ALL my web app classes and libs in the common folder for them to be found by
the engine.  When the jars are in <webapp>/WEB-INF/Lib, the scanner of the
folder sees them, but when it goes to unpack the jars, the context is lost
and it can't find them any more.  Am I missing a new env_var?  

Thanks

-----Original Message-----
From: Ray Madigan [mailto:ray@madigans.org]
Sent: Monday, September 23, 2002 12:04 AM
To: Tomcat Users List
Subject: Tomcat 4.1 Installation


Hi,

I have a set of webapps that run ok on tomcat 4.0 - except for the fact that
the responseDispatcher.include puts the included page at the beginning of
the including html page.  I have installed tomcat 4.1.10 and am attempting
to get it to work.  The problem is in the startup of the server when it is
deploying the contexts.  I have included the log message.  Any help would be
appreciated.

2002-09-22 22:26:05 HostConfig[localhost]: Expanding web application archive
Central.war
2002-09-22 22:26:05 StandardHost[localhost]: Installing web application at
context path /Central from URL file:/usr/local/xrm/webapps/Central
2002-09-22 22:26:05 WebappLoader[/Central]: Deploying class repositories to
work directory /usr/local/xrm/work/Standalone/localhost/Central
2002-09-22 22:26:05 WebappLoader[/Central]: Deploy class files
/WEB-INF/classes to /usr/local/xrm/webapps/Central/WEB-INF/classes
2002-09-22 22:26:05 WebappLoader[/Central]: Deploy JAR
/WEB-INF/lib/Central.jar to
/usr/local/xrm/webapps/Central/WEB-INF/lib/Central.jar
2002-09-22 22:26:05 WebappLoader[/Central]: Deploy JAR
/WEB-INF/lib/Partition.jar to
/usr/local/xrm/webapps/Central/WEB-INF/lib/Partition.jar
2002-09-22 22:26:05 WebappLoader[/Central]: Deploy JAR
/WEB-INF/lib/Proxy.jar to
/usr/local/xrm/webapps/Central/WEB-INF/lib/Proxy.jar
2002-09-22 22:26:06 ContextConfig[/Central] Exception processing JAR at
resource path /WEB-INF/lib/Proxy.jar
javax.servlet.ServletException: Exception processing JAR at resource path
/WEB-INF/lib/Proxy.jar
	at
org.apache.catalina.startup.ContextConfig.tldScanJar(ContextConfig.java:930)

...

----- Root Cause -----
java.io.IOException: No such file or directory
	at java.io.UnixFileSystem.createFileExclusively(Native Method)
	at java.io.File.checkAndCreate(File.java:1294)
If anyone has seen this - or has any idea of what to do - i would appreciate
it.

Thanks


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message