tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas T. Veldhouse" <ve...@veldy.net>
Subject Re: WebDav support -- what am I doing wrong?
Date Fri, 20 Sep 2002 23:22:11 GMT
Responding to my own post.  I am able to view the files in my webapp.  I had
to use the URL http://host:8080/mywebapp/

Apparently DreamWeaver adds the webdav onto the end of it by default.
However, I am not able to write to the app.  I have read-only set to false.
I have a role setup and have loaded the security constraints into web.xml.

Can anybody help?

Thanks in advance,

Tom Veldhouse

----- Original Message -----
From: "Thomas T. Veldhouse" <veldy@veldy.net>
To: "Tomcat Users" <tomcat-user@jakarta.apache.org>
Sent: Friday, September 20, 2002 5:22 PM
Subject: WebDav support -- what am I doing wrong?


> I am trying to setup webdav support for my webapp, but I am not succeeded,
> not even a little.  I can not get tomcat to listen for WebDav requests and
> trying to access it from DreamWeaver has not worked.
>
> I have tried: http://host:8080/WebDAV/mywebapp/
>
> No good.  I have the following in that webapps web.xml:
>
> <?xml version="1.0" encoding="ISO-8859-1"?>
>
> <!DOCTYPE web-app
>     PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
>     "http://java.sun.com/dtd/web-app_2_3.dtd">
>
> <web-app>
>
>   <servlet>
>     <servlet-name>webdav</servlet-name>
>
> <servlet-class>org.apache.catalina.servlets.WebdavServlet</servlet-class>
>     <init-param>
>       <param-name>debug</param-name>
>       <param-value>0</param-value>
>     </init-param>
>     <init-param>
>       <param-name>listings</param-name>
>       <param-value>true</param-value>
>     </init-param>
>     <!-- Uncomment this to enable read and write access -->
>     <init-param>
>       <param-name>readonly</param-name>
>       <param-value>false</param-value>
>     </init-param>
>     <load-on-startup>1</load-on-startup>
>   </servlet>
>
>   <!-- The mapping for the webdav servlet -->
>   <servlet-mapping>
>     <servlet-name>webdav</servlet-name>
>     <url-pattern>/</url-pattern>
>   </servlet-mapping>
>
>
> Plus, I added alot of the MIME mapping stuff.
>
> Can anybody tell me what I am doing wrong -- or not doing at all?
>
> Thanks in advance,
>
> Tom Veldhouse
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>
>



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message