tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Bengts <mar...@click3.jsp.fi>
Subject Re: mod_webapp or perhaps apache question
Date Fri, 02 Aug 2002 21:25:42 GMT
On Fri, 2 Aug 2002 rsequeira@transentric.com wrote:

>
> What's the directory layout? Is "qvdintra" a directory?

> The WebAppDeploy syntax is:
>
> WebAppDeploy <application_name> <connection_name> <url_path>

qvdintra is an application name which is the same as the directory present
under my "webapps" directory. The connection works fine. My problem is
that the webmail should be served by apache and everything else by tomcat.

I want to have:

	WebAppDeploy qvdintra	defConn		/

But still I need to have apache serving urls that have /webmail in the
beginning of the path. (The webmail application is written in php.)


> In my apache conf I have these lines for a virtual host:
>
>     #
>     Alias /webmail /home/qvd/www/webmail
>     # Tomcat configurations
>     <IfModule mod_webapp.c>
>         WebAppDeploy qvdintra   defConn         /_
>     </IfModule>
>
> I don't want to have "_/" in my servlet urls, but if I remove '_' my
> webmail stops working. I want to send everything else to tomcat except for
> urls with "/webmail" in the beginning of the path.
>
> Can anyone help me with this configuration? I thought the alias before the
> WebAppDeploy would help, but it seems that order doesn't matter here.
>

       Markus



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message