tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John McMeeking <jmcm...@us.ibm.com>
Subject RE: Not able to start Tomcat 4.0.4 with IBM supplied Java 1.3.1
Date Wed, 21 Aug 2002 17:00:50 GMT
                                                                                          
                    
                                                                                         
                     
                                                                                         
                     


The java.policy file in the two JREs are identical (beyond comments).  I
made the java.security files identical, with no success.  I could not find
any .java.policy files on my machine.  And running on a Windows machine as
an administrator, I couldn't think of any permissions I could change -- no
read-only files, for example.


John  McMeeking


                                                                                         
                                    
                      "Sullivan, Mark E" <Mark.                                       
                                       
                      Sullivan@nav-                     To:       "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
     
                      international.com>                cc:                           
                                       
                                                        Subject:  RE: Not able to start Tomcat
4.0.4 with IBM supplied Java   
                      08/21/2002 11:10 AM                1.3.1                           
                                    
                      Please respond to "Tomcat                                          
                                    
                      Users List"                                                        
                                    
                                                                                         
                                    
                                                                                         
                                    



it seems to be a file permissions problem. Check the security settings
between the two jdks to see what is different. I do not know a lot about
how
java handles file permissions, but i would start under the
jdk/jre/lib/security directory. Also, i believe there is a .policy file
somewhere in each user's profile that is also checked. Also, you could try
changing the file permissions on the tomcat directory to wide-open, and
then
see if the ibm jdk starts

> -----Original Message-----
> From: John McMeeking [mailto:jmcmeek@us.ibm.com]
> Sent: Wednesday, August 21, 2002 10:55 AM
> To: tomcat-user@jakarta.apache.org
> Subject: Not able to start Tomcat 4.0.4 with IBM supplied Java 1.3.1
>
>
>
> I am trying to run Tomcat 4.0.4 with an IBM JRE 1.3.1 on
> Windows 2000.  I
> can start Tomcat with the Sun JRE (1.3.1_04) with out any
> problem.  But
> using the IBM JRE I get the following exception running startup:
>
> java.util.zip.ZipException: Access is denied
>         at java.util.zip.ZipFile.open(Native Method)
>         at java.util.zip.ZipFile.<init>(ZipFile.java:127)
>         at java.util.jar.JarFile.<init>(JarFile.java:138)
>         at java.util.jar.JarFile.<init>(JarFile.java:80)
>         at org.apache.catalina.loader.StandardClassLoader.
> addRepositoryInternal(StandardClassLoader.java:1216)
>         at org.apache.catalina.loader.StandardClassLoader.
> <init>(StandardClassLoader.java:200)
>         at org.apache.catalina.startup.ClassLoaderFactory.
> createClassLoader(ClassLoaderFactory.java:202)
>         at
> org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:138)
> Bootstrap: Class loader creation threw exception
> java.lang.IllegalArgumentException: addRepositoryInternal:
> java.util.zip.
> ZipException: Access is denied
>         at org.apache.catalina.loader.StandardClassLoader.
> addRepositoryInternal(StandardClassLoader.java:1246)
>         at org.apache.catalina.loader.StandardClassLoader.
> <init>(StandardClassLoader.java:200)
>         at org.apache.catalina.startup.ClassLoaderFactory.
> createClassLoader(ClassLoaderFactory.java:202)
>         at
> org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:138)
>
> Am I missing some Java package?   Do I need to change some
> settings in some
> property file?  Or does this look like a JRE bug I need to
> take up with
> IBM?
>
>
> John  McMeeking
>
>
> --
> To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.
org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.
org>





--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message