tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephan Orme <stephano...@panna.org>
Subject Tomcat+CGI+SSI
Date Wed, 14 Aug 2002 00:54:12 GMT
I'm using Tomcat 4.0.4 to serve dynamic and static pages. I can get includes
to work and I can get CGI's to work but I can't get included CGI's to work.
<you can pick your friends, you can pick your nose...>
Anyway, here's what works:

includes on .html pages:
<!--#include virtual="Shared/footer"-->

includes on .jsp pages:
<%@ include file="Shared/footer" %>

CGI that works:
http://localhost/PCW/cgi-bin/test-cgi

And here's what DOESN'T work (this is on a .html page)
<!--#include virtual="/cgi-bin/test-cgi"-->
<!--#include virtual="/PCW/cgi-bin/test-cgi"-->
<!--#include virtual="../../WEB-INF/cgi/test-cgi"-->

My Tomcat config file is completely standard - I uncommented the SSI and CGI
bits and renamed the appropriate .jar files but there are no other config
changes. Since both CGI's and includes work my assumption here is that the
SSI servlet doesn't call the CGI servlet. In other words when I call the CGI
from the URL it gets handled by the CGI servlet, and when I include it it
gets handled by the SSI servlet but what I need is for the SSI servlet to
call the CGI servlet which it doesn't do.

Or I could just be making all this up. Anyone want to set me straight? Or,
even better, just tell me how to make it work. I've a lot of trouble using
Tomcat with Apache so I'd prefer to avoid that route and go with a straight
Tomcat solution if at all possible.  TIA, steve


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message