tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Saravanan Bellan <SBel...@jareva.com>
Subject RE: Newbie questions
Date Thu, 15 Aug 2002 19:13:18 GMT
Servlets should have their mapping defined in WEB-INF/web.xml


> -----Original Message-----
> From: Jim Marnell [mailto:jlmswf@yahoo.com]
> Sent: Thursday, August 15, 2002 12:12 PM
> To: Tomcat Users List
> Subject: RE: Newbie questions
> 
> 
> 
> I had not added context entry's to server.xml. I added the 
> following and it still does not work:
> <!-- Tomcat Manager Context -->
>         <Context path="/manager" docBase="manager"
>          debug="0" privileged="true"/>
>         <!-- Tomcat jimbo Context -->
>         <Context path="/jimbo" docBase="jimbo"
>          debug="0" privileged="true"/>
>           
>         <!-- Tomcat Examples Context -->
> The examples entry looked complicated so I tried to emulate a 
> simple example (manager). Should that have worked?
> Also, I moved my servlet into the examples directory - did 
> not work - 404 not available. Restarted for both tries.
> /Jim
>  "Turner, John" wrote:
> 
> Did you add a Context entry in server.xml for jimbo? 
> Basically, wherever
> you see entries in server.xml for "examples", you need to do 
> the same thing
> for "jimbo", then restart tomcat
> 
> You can also put your servlet into the examples directory, 
> with the example
> servlets, and see if you can call it via
> http://localhost:8080/examples/Form1
> 
> John Turner
> jturner@NOSPAM.aas.com
> 
> 
> -----Original Message-----
> From: Jim Marnell [mailto:jlmswf@yahoo.com]
> Sent: Thursday, August 15, 2002 2:31 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Newbie questions
> 
> 
> 
> I'm having problems running a servlet. I've installed tomcat 
> 4.0.4, apache
> 2 & jdk 1.4 on redhat 7.2.
> 
> I put html file with the following into apache's htdocs directory
> 
> 
> 
> 
> I then created a directory in $tomcat_home/webapps called 
> jimbo. Within
> directory jimbo I created WEB-INF/classes and moved my 
> compiled servlet into
> it. I restarted tomcat and get a 404 message stating that Form1 is not
> available. Please let me know what is wrong.
> 
> Also, do I need any special apache modules for tomcat?
> 
> Thanks in advance.
> 
> /J
> 
> 
> 
> ---------------------------------
> Do You Yahoo!?
> HotJobs, a Yahoo! service - Search Thousands of New Jobs
> 
> --
> To unsubscribe, e-mail: 
> For additional commands, e-mail: 
> 
> 
> 
> ---------------------------------
> Do You Yahoo!?
> HotJobs, a Yahoo! service - Search Thousands of New Jobs
> 

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message