tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sullivan, Mark E" <Mark.Sulli...@nav-international.com>
Subject RE: BAD packet - Apache 2.0.39 + mod_jk (or mod_webapp) on linux
Date Tue, 20 Aug 2002 13:17:50 GMT
That's not necessarily true. I'm running mod_jk on rh 7.3 with apache 2.0.39
and tomcat 4+. I had no problems building or using the module. I don't
remember having to do anything special when building the module either.

> -----Original Message-----
> From: Turner, John [mailto:JTurner@AAS.com]
> Sent: Tuesday, August 20, 2002 8:08 AM
> To: 'Tomcat Users List'
> Subject: RE: BAD packet - Apache 2.0.39 + mod_jk (or mod_webapp) on
> linux
> 
> 
> 
> I just built apache 2.0.40 and tried to get it working with 
> mod_jk.so on RH
> 7.2.  No luck...the mod_jk.so file that works with 1.3.26 is 
> not compatible
> with 2.0.40.  The error message I get is:
> 
> Cannot load /usr/local/apache2/lib/mod_jk.so into server:
> /usr/local/apache2/lib/mod_jk.so: undefined symbol: ap_table_get
> 
> So, right off the bat, I can tell you that the instructions 
> in my How-To
> will only work with apache 1.3.26, not 2.0.39/40.  I will 
> have to research
> if it is a do-or-die problem with mod_jk (which means 
> switching to mod_jk2),
> or just a rebuild of mod_jk with options that allow use with apache
> 2.0.39/40.
> 
> John Turner
> 
> -----Original Message-----
> From: Turner, John [mailto:JTurner@AAS.com]
> Sent: Tuesday, August 20, 2002 8:15 AM
> To: 'Tomcat Users List'
> Subject: RE: BAD packet - Apache 2.0.39 + mod_jk (or mod_webapp) on
> linux
> 
> 
> 
> I notice you mentioned that you had copied the JAR files to
> CATALINA_HOME/common after building the connector.  This is 
> one area that
> confuses me about connecting apache to tomcat with mod_jk.  
> The docs I read
> told me to build those JARs, but I don't have them anywhere in my
> CATALINA_HOME tree, I left them in the source-build 
> directory.  As far as I
> can tell, they aren't needed.
> 
> This might be the problem, or, if it isn't, did you find a resource
> someplace that explained what the JAR files are for, where 
> they should go,
> and why?  I didn't find one, and would be interested in reading it.
> 
> My memory is hazy, too, but it seems to me that apache 2.x 
> requires mod_jk2,
> not mod_jk.  If I have a chance today I will build 2.0.39 
> from source and
> see if it works instead of 1.3.26 in my currently-working
> apache+tomcat+mod_jk environment.
> 
> John Turner
> jturner@NOSPAM.aas.com
> 
> 
> -----Original Message-----
> From: Mathew Pole [mailto:Mathew.Pole@clipsal.com.au]
> Sent: Tuesday, August 20, 2002 3:28 AM
> To: 'tomcat-user@jakarta.apache.org'
> Subject: BAD packet - Apache 2.0.39 + mod_jk (or mod_webapp) on linux
> 
> 
> Hi ,
> 
> At first glance the following combination sounded like a great idea
> (especially as I had success with this on windows 2000):
> tomcat 4.0.4 
> tomcat connectors 4.0.4 
> apache 2.0.39 
> linux (gentoo 1.2 distribution)
> In reality it has proved very challenging. I've tried the following:
> 
> Following instructions provided by John Turner in
> http://www.johnturner.com/howto/apache-tomcat-howto.html, I 
> came across a
> couple of issues which I resolved by 
> failed trying to build the mod_jk.so, but after setting 
> apache13.home to a
> bogus location and running ant native it appears to have worked 
> copied jk/build/lib/mod_jk.so apache2/modules 
> copied jk/build/lib/*.jar to tomcat/common 
> updated apache.conf file as suggested 
> updated server.xml as suggested, with addition of
> modJk="/usr/local/apache2/modules/mod_jk.so" in the listener 
> definition
> Currently, in the tomcat/logs/catalina.out file the following text is
> appearing (note the string after In : : [ changes, but 4/843 remains
> constant):
> 
>    BAD packet 256
>    In: : [B@3e58d4 4/843
> 
> followed by what appears to be some hex output of mainly 00s.
> 
> My suspicion is that this error is caused by one of:
> mod_jk.so being compiled incorrectly 
> connector jar files being compiled incorrectly or being in 
> the wrong place 
> incorrect configuration
> I've also attached logs & configuration files to this email. 
> Hopefully this
> is enough information for someone to help me.
> 
> In addition to this I looked at the instructions in
> http://wass.homelinux.net/howtos/Jakarta_How-To.shtml, but the
> mod-jk-303-ap20.so doesn't work with apache 2.0.39.
> 
> 
> 
> Regards,
>    Mathew
> --
> Mathew Pole 
> Web Architect, Gerard Industries
> email: mathew.pole@clipsal.com.au
> phone: 08 8269 0511 ext 313, fax: 08 8340 1212, mobile: 0403 164 617
> 
> --
> To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> 
> --
> To unsubscribe, e-mail:   
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message