tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From micael <caraun...@harbornet.com>
Subject Re: JVM crashes when using JSSE
Date Wed, 28 Aug 2002 17:37:11 GMT
Is everyone getting all the repeats on this list that I am?

At 01:40 PM 8/27/2002 -0700, you wrote:
>Subject: Re: JVM crashes when using JSSE
>From: "Tim Koop" <tvkoop@hotmail.com>
>  ===
>In case you're curious, I tried it with Sun's Java SDK 1.4.1 and all works
>fine.
>
>Tim Koop
>www.timkoop.com
>
>----- Original Message -----
>From: "Tim Koop" <tvkoop@hotmail.com>
>To: <tomcat-user@jakarta.apache.org>
>Sent: Friday, August 23, 2002 4:08 PM
>Subject: JVM crashes when using JSSE
>
>
> > I have Tomcat working fine, but when I try to get the SSL working using
> > JSSE, by uncommenting the lines in server.xml, Java crashes on me.
> >
> > I installed Tomcat 4.0.4 with the tomcat4-4.0.4-full.2jpp.noarch.rpm rpm.
> > I installed Java SDK 1.3.1 with the IBMJava2-SDK-1.3.1-2.0.i386.rpm rpm.
> >
> > It all works fine till here.
> >
> > Then I found the following files and put them in
> > /opt/IBMJava2-131/jre/lib/ext/
> > jcert.jar
> > jnet.jar
> > jsse.jar
> >
> > Then I ran the keytool, just like the instructions said and put the
> > .keystore file in the tomcat4 directory.
> >
> > Then I uncommented the following lines in /var/tomcat4/conf/server.xml
> >     <!-- Define an SSL HTTP/1.1 Connector on port 8443 -->
> >     <Connector
>className="org.apache.catalina.connector.http.HttpConnector"
> >                port="8443" minProcessors="5" maxProcessors="75"
> >                enableLookups="true"
> >                acceptCount="10" debug="0" scheme="https" secure="true">
> >       <Factory className="org.apache.catalina.net.SSLServerSocketFactory"
> >                clientAuth="false" protocol="TLS"/>
> >     <keystoreFile>/var/tomcat4/</keystoreFile>
> >     </Connector>
> >
> >
> > When I restart at this point, I get the following error, which I concluded
> > was a JVM core dump:
> >         stackpointer=0xbfffeda8
> > Writing Java core file ....
> > Written Java core to /tmp/javacore9253.1030108102.txt
> >
> > I'm using a fresh install of Linux Red Hat 7.3
> >
> > Can anyone give me any ideas on how to get this working?
> >
> > Thanks in advance.
> >
> > Tim Koop
> >
> >
> >
> >
> >
> >
> > --
> > To unsubscribe, e-mail:
><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
><mailto:tomcat-user-help@jakarta.apache.org>
> >
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message