tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eddie Bush <>
Subject RPM Upgrade from 4.0.4 - error: failed dependencies:
Date Wed, 21 Aug 2002 20:38:35 GMT
Hi, I was wondering if someone could tell me why the LE version has a 
dependency on jaxp/xml api/commons logging.  This is all functionality 
found in J2SDK 1.4 (hence the LE version), right?  My guess is that the 
packages contain "better versions" - is this correct?  My SDK install 
was via RPM as well.  I'm going to hold off on the upgrade until I get a 
signal that these dependencies are actually needed.  I don't mind adding 
commons logging and log4j, as I use them anyway, and like the idea of a 
RPM install.  However, the jaxp/xml api stuff has thrown me for a loop. 
 I really don't think any of these dependencies should exist.

error: failed dependencies:
        jaxp_parser_impl is needed by tomcat4-4.1.9-le.1jpp
        xml-commons-apis is needed by tomcat4-4.1.9-le.1jpp
        jakarta-commons-logging >= 1.0.1 is needed by tomcat4-4.1.9-le.1jpp

I know someone out there knows if these are true requirements, or if 
this is perhaps a misconfiguration in building the RPMs.  I would 
appreciate it if they would step forward and clearify this point for me. 

I can't say how shocked I was to find RPMs for the beta to begin with. 
 I suppose kudos for that go out to Henri (and, I'm sure, many others as 
well).  I, for one, really appreciate it!



To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message