tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From MadBit <mad...@telepolis.com>
Subject Re: .shtml with 4.0.4
Date Mon, 12 Aug 2002 22:07:13 GMT

     Any changes to httpd.conf or web.xml files? I have a 404 from
tomcat. The pages are located on apache.

rsequeira@transentric.com escribió::

 >First the <servlet code...></servlet> isn't supported by Tomcat. It 
isn't a
 >standard tag i.e. it isn't defined in the servlet specs. You should use
 ><jsp include /> instead. Convert  the .shtml files (be careful if you have
 >SSI includes or CGI processing in the shtml files) that contain the
 ><servlet> tags to .jsps.
 >And then replace the
 ><servlet code="classpath.Class"></servlet>
 >with
 ><jsp:include page="/servlet/classpath.Class" flush="true"/>
 >
 >
 >RS
 >
 >
 >
 >
 > 

 >                      MadBit 

 >                      <madbit@telepolis        To: 
tomcat-user@jakarta.apache.org
 >                      .com>                    cc: 

 >                                               Subject:  .shtml with 
4.0.4
 >                      08/12/02 04:45 AM 

 >                      Please respond to 

 >                      "Tomcat Users 

 >                      List" 

 > 

 > 

 >
 >
 >
 >
 >
 >    Hello.
 >
 >    I'm using Tomcat 4.0.4 with Apache 1.3.26 on Windows 2000.
 >
 >    I want to use .shtml pages. In tomcat I enabled de SSI servlet and
 >mapping on web.xml,
 >and on Apache I enabled the AJP connector and enabled .shtml processing:
 >
 >
 >
 >>LoadModule jk_module modules/mod_jk.dll
 >>Addmodule mod_jk.c
 >>
 >>JkWorkersFile /webprg/tomcat/conf/jk/workers.properties
 >>JkLogFile /webprg/apache/logs/mod_jk.log
 >>JkLogLevel info
 >>
 >>
 >
 >....
 >
 >AddType text/html .shtml
 >AddHandler server-parsed .shtml
 >
 >...
 >JkMount /*.jsp ajp13
 >JkMount /servlet/* ajp13
 >JkMOunt /*.shtml ajp13
 >
 >    On a .shtml page I have a <servlet code="classpath.Class"></servlet>
 >call. The called Class it's working fine calling directely via
 >'localhost/servlet/classpath.Class' URL but with the .shtml the Class
 >seems not to be called and the browser never end to load the page,
 >always it's on awaiting data state.
 >
 >    Anyone can help me?
 >
 >   Thanks
 >
 >
 >Rogelio Herranz
 >madbit@telepolis.com
 >
 >
 >
 >--
 >To unsubscribe, e-mail:   <
 >mailto:tomcat-user-unsubscribe@jakarta.apache.org>
 >For additional commands, e-mail: <
 >mailto:tomcat-user-help@jakarta.apache.org>
 >
 >
 >
 >
 >
 >
 >
 >--
 >To unsubscribe, e-mail: 
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
 >For additional commands, e-mail: 
<mailto:tomcat-user-help@jakarta.apache.org>
 >
 >
 >
 >






--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message