tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AMRAN...@aol.com
Subject Tomcat not encrypting connection
Date Thu, 08 Aug 2002 18:17:40 GMT
HI

I have just followed the Tomcat SSL HOWTO and I am able to get my 
https://localhost:443/ page. I then right-click on my mouse to get up the 
page properties; 

Protocol:            Hyper Text Transfer With Privacy
Type:                 HTML Document
Connection:        Not Encrypted
Address(URL):    https://localhost:443/index.html
Size:                  2572 bytes


but it says the page is not encrypted why does this happen? should it not 
state some sought of encryption like 128 bit?

I also tried the Apache + mod_ssl HOWTO and I do get an encrypted connection 
which says the following;

Connection:    TLS 1.0, RC4 with 128 bit encryption (High); RSA with 1024 bit 
exchange

I have apache 1.3.26 (Linux box) + mod_jk + Tomcat 4.04 (Windows box)

The Tomcat server in my environment handles login forms processes them and 
then puts the user to their homepage. I wish to encrypt this login process. I 
don't think I need to use apache +mod_ssl to do any connection encryption 
because the login form is sent to the Tomcat server.  

I cannot figure out what I am missing? Can anyone help please?

Thanxs in Advance

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message