tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Carpani <>
Subject ajp13 threads blocking
Date Mon, 19 Aug 2002 14:59:51 GMT
Hi everybody: I'm experiencing a strange and randomic problem with my
tomcat configuration. Here's the software: I'm using Tomcat 4.0.4 with
sun's jdk 1.3.1_04 as a servlet and jsp container, behind a 1.2.36
Apache web server.

CATALINA_OPTS="-server -ms256m -mx512m -Xss32k"

The server starts up fine, but after a (more or less) 12 hours running
time something breaks (loks up?) and I get these on mod_jk.log:

[Mon Aug 19 03:21:52 2002]  [jk_ajp_common.c (1009)]: Error reading
[Mon Aug 19 03:21:52 2002]  [jk_ajp_common.c (1146)]: In
jk_endpoint_t::service, ajp_get_reply failed in send loop 0
[Mon Aug 19 03:21:52 2002]  [jk_ajp_common.c (651)]:
ajp_connection_tcp_get_message: Error - jk_tcp_socket_recvfull failed

At this point jakarta is more or less hung and there's little you can do
with it: one option is to restart it, another is to restart the apache
web server and everything seems to run fine for another 12 h or so.

I've had tomcat running under a java profiler and it looks like the
ajp13 threads are all "blocked" when things go wrong.

Is this a known bug?

- .a.c.    
- Andrea Carpani
- <>

http://www.vitaminic.[it|com||de|es|fr|nl|se|dk|ie] (
DISCLAIMER, PLEASE NOTE: This communication is intended only for use by
addressee. It may contain confidential or privileged information.
Transmission, distribution and/or copy cannot be permitted. Please
Vitaminic Spa immediately by reply e-mail if you are not the intended
recipient. Vitaminic Spa does not accept liability for corruption,
interception or amendment, if any, or the consequences thereof.

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message