tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niket Anand" <niketan...@npi.stpn.soft.net>
Subject Re: BAD packet - Apache 2.0.39 + mod_jk (or mod_webapp) on linux
Date Tue, 20 Aug 2002 08:05:05 GMT
Hi Mathew,
Can I get same type of instructions for Apache2.0.4,JBoss-2.4.6_Tomcat-4.0.3,jakarta-tomcat-connectors-4.0.4-src,
JDK1.3.1 on Win2000?

Thanks,
Niket
  ----- Original Message ----- 
  From: Mathew Pole 
  To: 'tomcat-user@jakarta.apache.org' 
  Sent: Tuesday, August 20, 2002 12:57 PM
  Subject: BAD packet - Apache 2.0.39 + mod_jk (or mod_webapp) on linux


  Hi ,

  At first glance the following combination sounded like a great idea (especially as I had
success with this on windows 2000):
    a.. tomcat 4.0.4 
    b.. tomcat connectors 4.0.4 
    c.. apache 2.0.39 
    d.. linux (gentoo 1.2 distribution)
  In reality it has proved very challenging. I've tried the following:

  Following instructions provided by John Turner in http://www.johnturner.com/howto/apache-tomcat-howto.html,
I came across a couple of issues which I resolved by 
    a.. failed trying to build the mod_jk.so, but after setting apache13.home to a bogus location
and running ant native it appears to have worked 
    b.. copied jk/build/lib/mod_jk.so apache2/modules 
    c.. copied jk/build/lib/*.jar to tomcat/common 
    d.. updated apache.conf file as suggested 
    e.. updated server.xml as suggested, with addition of modJk="/usr/local/apache2/modules/mod_jk.so"
in the listener definition
  Currently, in the tomcat/logs/catalina.out file the following text is appearing (note the
string after In : : [ changes, but 4/843 remains constant):

     BAD packet 256
     In: : [B@3e58d4 4/843

  followed by what appears to be some hex output of mainly 00s.

  My suspicion is that this error is caused by one of:
    a.. mod_jk.so being compiled incorrectly 
    b.. connector jar files being compiled incorrectly or being in the wrong place 
    c.. incorrect configuration
  I've also attached logs & configuration files to this email. Hopefully this is enough
information for someone to help me.

  In addition to this I looked at the instructions in http://wass.homelinux.net/howtos/Jakarta_How-To.shtml,
but the mod-jk-303-ap20.so doesn't work with apache 2.0.39.



  Regards,
     Mathew
  --
  Mathew Pole 
  Web Architect, Gerard Industries
  email: mathew.pole@clipsal.com.au
  phone: 08 8269 0511 ext 313, fax: 08 8340 1212, mobile: 0403 164 617



------------------------------------------------------------------------------


  --
  To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
  For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message