tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CouasPhilippe <pco...@infodev.fr>
Subject CGI newbie question
Date Tue, 20 Aug 2002 20:41:28 GMT
Hi, everyBody


I have a CGI problem with Tomcat 4.0.4 standalone on AIX 4.3.3.0 


1 my CGI are on my server in /home/httpd/cgi-bin/Keyword

2 web.xml is here
<servlet>                                                                
  <servlet-name>cgi</servlet-name>                                       
  <servlet-class>org.apache.catalina.servlets.CGIServlet</servlet-class> 
  <init-param>                                                           
    <param-name>clientInputTimeout</param-name>                          
    <param-value>100</param-value>                                       
  </init-param>                                                          
  <init-param>                                                           
    <param-name>debug</param-name>                                       
    <param-value>6</param-value>                                         
  </init-param>                                                          
  <init-param>                                                           
    <param-name>cgiPathPrefix</param-name>                               
    <param-value>/home/httpd</param-value>                               
  </init-param>                                                          
   <load-on-startup>5</load-on-startup>                                  
 </servlet>  

3 servlets-cgi.jar  is Ok

4 my html file

<form
        action="/cgi-bin/Keyword/search.cgi" method="POST">
            <p align="center"><font color="#FFFF00"><b>Recherche</b></font></p>
            <p><font color="#FFFF00">Mot(s) Clef(s):</font> <br>
            <input type="text" size="19" maxlength="256"
            name="keywords"></p>
            <p><input type="checkbox" name="exact_match"><font
            color="#FFFF00">mots exacts</font></p>
            <p align="center"><input type="submit"
            value="Rechercher"> </p>
        </form>



5 http://172.16.0.101:8080/cgi-bin/Keyword/search.cgi give me an error 404 

Where is my mistake

                                                            

Thanks 

	Philippe


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message