tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Larsen" <lar...@qec.com>
Subject Re: Apache + Tomcat sometimes pegs CPU
Date Fri, 02 Aug 2002 17:05:46 GMT
I forgot to mention... Even when the CPU is pegged,
the site functions normally.

Jeff

----- Original Message -----
From: "Jeff Larsen" <larsen@qec.com>
To: "tomcat-user" <tomcat-user@jakarta.apache.org>
Sent: Friday, August 02, 2002 12:02 PM
Subject: Apache + Tomcat sometimes pegs CPU


> I'm running Apache 1.3.23/Tomcat 4.0.3 (jdk1.3.1)
> on Solaris 7 connected with mod_jk. Sometimes I
> I find that the CPU on the web server box is pegged
> at 100%. It's a dedicated server and I am bouncing
> Apache and Tomcat once a week to help alleviate the
> problem. If I didn't restart every week, it would just
> be a matter of time before things spiraled out of
> control again.
>
> The processes that are responsible are java (Tomcat)
> and libhttpd.ep (Apache, with --enable-rule=SHARED_CORE)
> each with about 50% of the CPU.
>
> If I bounce Tomcat, no change. If I bounce Apache,
> it returns to normal (low) CPU usage. I have Apache
> running on other machines without Tomcat and this
> does not happen.
>
> So it's got to be a mod_jk thing. There are no log
> messages of any significance. Any ideas on how to
> fix it?
>
> Thanks,
>
> Jeff
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message