tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Orledge" <borle...@rsimail.com>
Subject RE: Can't get tomcat 4 + mod_jk + apache to work
Date Tue, 20 Aug 2002 13:35:21 GMT
Did you get anywhere with this.  I'm using the same configuration (minus
the JBoss) and having the same error.


Brian Orledge
Revenue Solutions, Inc.
301.240.2182

-----Original Message-----
From: Scott Adamson [mailto:scottadamson@jc.com.au] 
Sent: Monday, August 19, 2002 11:57 AM
To: Tomcat Users List
Subject: Can't get tomcat 4 + mod_jk + apache to work


I have been trying for the last week to get Apache + mod_jk + Tomcat 4
to
work.
I have confirmed that Tomcat works on 8080, confirmed that Apache is
running.

My configuration is as follows :

    OS -
    Redhat Linux 6.2

    Java -
    JAVA_HOME="/usr/java/jdk1.3"
    Installed via RPM

    Tomcat -
    Installed binary distribution of jakarta 4.0.4 at
/usr/local/jakarta-tomcat-4.0.4
    Created jakarta-tomcat-4.0.4/conf/jk/workers.properties as follows :

        workers.tomcat_home=/usr/local/jakarta-tomcat-4.0.4
        workers.java_home=/usr/java/jdk1.3
        ps=/
        worker.list=ajp12, ajp13
        worker.ajp13.port=8009
        worker.ajp13.host=toecutter
        worker.ajp13.type=ajp13

    Modified jakarta-tomcat-4.0.4/conf/server.xml as follows : (see
attached)

        <Server port="8005" shutdown="SHUTDOWN" debug="0">
   #added line          <Listener
className="org.apache.ajp.tomcat4.config.ApacheConfig"
modJk="/usr/local/apache2/libexec/mod_jk-3.3-ap13-noeapi.so" />
....
and

      <Host name="toecutter" debug="0" appBase="webapps"
unpackWARs="true">
    #added line       <Listener
className="org.apache.ajp.tomcat4.config.ApacheConfig" append="true"
forwardAll="false" />

    Apache -
    Compiled Apache1.3.19 with the following config -
./configure --prefix=/usr/local/apache2 --enable-module=so
    Added the following to httpd.conf (see attached)
        Include /usr/local/jakarta-tomcat-4.0.4/conf/auto/mod_jk.conf

    mod_jk -
    Added the binary mod_jk-3.3-ap13-noeapi.so to
/usr/local/apache2/libexec


/apache2/logs/error_log contains the following :

[Tue Aug 20 02:08:20 2002] [error] [client 192.168.0.7] File does not
exist:
/usr/local/apache2/htdocs/examples/

indicating that it isn't even trying to redirect and looks for /examples
under /apache2/htdocs
Can someone please help me (thanks to those who have already tried), can
someone see a problem with my configuration ?



Scott Adamson
Systems Administrator
Syware Technology

scottadamson@sywaretech.com.au
http://upe.com.au




--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message