tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Conrad" <andrewcon...@attbi.com>
Subject RE: Can't start jk_nt_service...
Date Thu, 22 Aug 2002 22:04:28 GMT
I haven't ever needed to use jk_nt_service.  If you download the EXE
version of Tomcat, the installer allows you to install Tomcat as a
service.

http://jakarta.apache.org/builds/jakarta-tomcat-4.0/release/v4.0.4/bin/

- Andrew

> -----Original Message-----
> From: Alex Tait [mailto:atait@claritycon.com] 
> Sent: Thursday, August 22, 2002 5:31 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Can't start jk_nt_service...
> 
> 
> Following the very helpful instructions at 
> http://members.ozemail.com.au/~lampante/howto/tomcat/iisnt/ 
> from an earlier e-mail in this list, I have successfully 
> installed Tomcat 4.0.4 and JDK 1.3 on my Windows XP machine.  
> Tomcat is successfully serving pages to the 8080 port.  I 
> even have the IIS redirect working for jsp.
> 
> But, I'm running into difficulties getting the jk_nt_service 
> Windows service running.  
> 
> I successfully installed it using the command:
> "jk_net_service -i Tomcat -a wrapper.properties", but I can't 
> start it with the "jk_nt_service -s Tomcat" command.  
> 
> The response I get is:
> Asked (and given) winsock 1.1
> Starting tomcat.
> tomcat failed to start. 
> 
> I also can't start it from the Windows Services MMC (no 
> surprise given that I can't start it at the command prompt).  
> The response I get is "The Tomcat service on Local Computer 
> started and then stopped.  Some services stop automatically 
> if they have no work to do, for example, the Performance Logs 
> and Alert service."
> 
> Everytime I try to start the service, the Windows system 
> records one log that says, "The Tomcat service was 
> successfully sent a start control" followed by another system 
> log that says, "The Tomcat service entered the stopped 
> state."  These logs are written when I try to start the 
> service through the Services MMC or the command prompt.
> 
> I can't find any entries in any of the Tomcat logs that 
> correlate to the times I try to start the service so that 
> doesn't seem to be any help.  I also can't find any other useful logs.
> 
> In searching the e-mail archives I found another reference to 
> this problem, but the thread died before any solution came 
> about.  Any direction will be greatly appreciated.
> 
> Thanks,
> Alex
> 
> 
> --
> To unsubscribe, e-mail:   
> <mailto:tomcat-user-> unsubscribe@jakarta.apache.org>
> For 
> additional commands, 
> e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
> 
> 


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message