tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael" <mich...@idtect.com>
Subject RE : Can someone explain catalina.home & catalina.base?
Date Wed, 21 Aug 2002 09:27:53 GMT
>      > Basically I want to deploy
>      > my webapp without modifying ANY files under the CATALINE_HOME
>      > directory (where I installed Tomcat).  
> 
> Which  directories do  you have  under CATALINA_BASE?  Is  
> your webapp under CATALINA_BASE or under CATALINA_HOME?
> 
> Please  take  a  look at  the  RUNNING.txt  (Point  (4)) file 
>  in  the CATALINA_HOME directory.

Ok, here is a lot more detail with what I've tried.  I've spent hours on
this to no avail so I greatly appreciate your help.

Server.xml contains:

        <Context reloadable="true"
                 debug="10"
                 docBase="c:\idtect\projects\oemserver\web"
                 path="/oemserver"
                 />

I then go to DOS and type:

C:\>%CATALINA_HOME%\bin\startup
Using CATALINA_BASE:   c:\idtect\projects\oemserver\conf\tomcat
Using CATALINA_HOME:   c:\devapps\tomcat
Using CATALINA_TMPDIR: c:\idtect\projects\oemserver\conf\tomcat\temp
Using JAVA_HOME:       C:\devapps\j2sdk1.4.1
C:\>

This starts up Tomcat.  I know it's finding my web.xml because it is
starting up a servlet and I see the servlet's output.  The problem is I
cannot access my webapp with the /oemserver URL in the browser.  

I try : 

http://localhost:8080/oemserver/

And receive : 

Apache Tomcat/4.0.4 - HTTP Status 404 - /oemserver/
------------------------------------------------------------------------
--------
type Status report
message /oemserver/
description The requested resource (/oemserver/) is not available.
------------------------------------------------------------------------
--------
 
In the access log I see:

127.0.0.1 - - [21/Aug/2002:11:23:00 1000] "GET /oemserver/ HTTP/1.1" 404
606

I have the debug levels to "10" and in the localhost_log.txt I get the
following error for EVERY ONE of my jar files in my WEB-INF/lib
directory:

2002-08-21 11:14:00 ContextConfig[/oemserver]:
tldConfigJar(/WEB-INF/lib/struts.jar): java.io.IOException: Le chemin
d'acces specifie est introuvable

The error message in english says "the path specified does not exist".
This I don't understand because my JAR's are in the WEB-INF/lib
directory.  Later in the localhost_log.txt I see:

2002-08-21 11:14:01 action: init
2002-08-21 11:14:01 timerservlet: init
2002-08-21 11:14:01 StandardContext[/oemserver]: Starting completed

Which tells me the struts servlet initialized, my custom servlet
initialized, and the oemserver webapp is started.  But why can't I
access the webapp in the browser???

I tried deploying the /examples webapp but although I do not get the
problem with the JARs I still get the 404 errors when I try to access
the page.

Finally, if I set CATALINA_HOME & CATALINA_BASE back to the tomcat
installation directory, I can use -config <path to my server.xml> and my
webapp works fine.  So that tells me my server.xml and web.xml are OK.

Thanks for your help!
Michael


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message