tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <r...@apache.org>
Subject Re: [4.1.6] Milestone available for testing
Date Mon, 01 Jul 2002 07:44:37 GMT
Mladen Turk wrote:
> 
>>>Doesn't work :(
>>>
>>>Direct conf and dir replacement for working 4.1.5.
>>>JSDK 1.4.0_01/WIN XP
>>>Standalone.
>>>
>>>http://localhost:8080/examples/jsp/dates/date.jsp
>>
>>The same configuration (XP Home / JDK 1.4.0_01) works very 
>>well for me.
>>
>>Remy
>>
> 
> 
> If started through shortcut (well, I left the one from 4.15
> installation) then it doesn't work, but if started clicking on the
> startup.bat directly then it works.

When you install Tomcat, it copies javac to the Tomcat common/lib 
(otherwise, there could be problems with path lengths in the shortcuts). 
So if you install with JDK 1.3, and then swicth later to JDK 1.4, the 
rt.lib from JDK 1.4 will be used by the javac from JDK 1.3, and that 
will cause an error.

The easiest is probably to update tools.jar in common/lib, or to avoid 
switching JDKs.

The error massage I get is:
Generated servlet error:
     [javac] Compiling 1 source file
C:\Program Files\Apache Group\Tomcat 
4.1\work\Standalone\localhost\examples\jsp\dates\date$jsp.java:11: 
cannot access java.lang.Object
bad class file: C:\java\j2sdk1.4.0_01\jre\lib\rt.jar(java/lang/Object.class)
class file has wrong version 48.0, should be 47.0
Please remove or make sure it appears in the correct subdirectory of the 
classpath.
   private static java.util.Vector _jspx_includes;
                  ^
1 error

Remy


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message