tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brendan.Richa...@lowelive.com
Subject Re: mod_jk /examples/* works but /servlet/* doesn't
Date Fri, 21 Jun 2002 14:16:09 GMT

I don't know if this will work or not...

but have you tried:

JkMount /servlet/** ajp13

If it works, let me know...

Brendan

--------------------------------------------

Hi Everyone,
Recently I have connected apache with tomcat using mod_jk. In my httpd.conf
file I am giving this directive.
JkMount /examples/* ajp13

It works perfectly fine but problem is it forwards all requests to apache.
I
want static requests to be handled by Apache.
As per documentation only these two directives should be sufficient
JkMount /*.jsp ajp13
JkMount /servlet/* ajp13

But with above config I am not able to get my servlets working. From mod_jk
logs (after changing log level to debug) I came to know these requests are
not being forwarded to tomcat and apache try to handle these requests
itself
:(
I tried with this directive instead
JkMount /examples/servlet/* ajp13

And it's working perfectly. But with this everytime I add new context, I
have to add new directive for this context's servlet :(.  I don't want
that.
Document says "JkMount /servlet/* ajp13"  should work but isn't working !!
Any idea why.
I have tried all combinations */servlet/*, *servlet/* but no use.
I am using apache 1.3.24, Tomcat 4.0.2, JDK 1.3, Windows 2000

Any help would be greatly appreciated.

Thanks
Avnish


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>




--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message