tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Fenlason" <jfenla...@ptc.com>
Subject JNDIRealm authentication
Date Wed, 12 Jun 2002 18:18:50 GMT
I'm trying to do LDAP authentication with Tomcat 4.1.3.  I've read through
the how to docs on Tomcat's site,
http://jakarta.apache.org/tomcat/tomcat-4.1-doc/realm-howto.html#JNDIRealm,
and tried to follow the example.  My site loads fine, but I never get an
authentication prompt when I enter my site.  If anyone could sees anything
wrong with my <Realm/> or has any ideas of where else I should need to
change things, I would greatly appreciate it.  Thanks.
,
Josh.

Here's what I entered for the Realm element in
<tomcat4.1.3_home>/conf/server.xml

<Realm className="org.apache.catalina.realm.JNDIRealm"
    connectionName="ou=People,ou=jfenlason_r62DC,ou=jfenlason,l=Arden
Hills,o=Bethel"
    connectionPassword="secret"
    connectionURL="ldap://corvette.mn.ptc.com:389"
    roleName="oid"
    roleSearch="(uniqueMember={0})"
    userPassword="userPassword"
    userPattern="oid={0},ou=People,ou=jfenlason_r62DC,ou=jfenlason,l=Arden
Hills,o=Bethel"
    debug="99"/>

Here's the AuthLDAPURL that works with Apache1 doing the authentication
ldap://corvette.mn.ptc.com:389/ou=People,ou=jfenlason_r62DC,ou=jfenlason,l=A
rden Hills,o=Bethel"


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message