tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: Solaris 2.6
Date Thu, 13 Jun 2002 13:34:10 GMT
Howdy,
Simple test: go to your $JAVA_HOME/jre/lib, do 
jar tvf rt.jar | grep ArrayList
if you're running 1.3.1, you should see two lines, one for
java/util/ArrayList and one for java/util/Arrays$ArrayList.

If they're not there, you're not using 1.3.1. ;)

I think I saw an earlier post from you saying you were getting this
error using java 1.1.3.  That JDK does not have the Collections
framework (to which ArrayList belongs).  Tomcat 4.x needs the
collections framework, hence use JDK 1.2 or later.

Yoav Shapira
Millennium ChemInformatics


>-----Original Message-----
>From: Matthew Oatham [mailto:Matthew.Oatham@AssetHouse.com]
>Sent: Thursday, June 13, 2002 3:09 AM
>To: 'tomcat-user@jakarta.apache.org'
>Subject: Solaris 2.6
>
>Hi,
>
>I have installed Tomcat 4.0.3 (jakarta-tomcat-4.0.3.tar.gz) on Solaris
2.6.
>When running shutdown.sh the following exception is thrown:
>
>Bootstrap: Class loader creation threw exception
>java.lang.NoClassDefFoundError: java/util/ArrayList
>        at
>org.apache.catalina.startup.ClassLoaderFactory.createClassLoader(Compil
ed
>Code)
>        at org.apache.catalina.startup.Bootstrap.main(Compiled Code)
>
>I believe the machine is running Java 1.3.1.
>
>Has anyone come across this problem before?
>
>Many thanks.
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-
>unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-
>help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message