tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Douglas, Rory" <Rory.Doug...@na.sunchem.com>
Subject RE: weird connection problems
Date Fri, 28 Jun 2002 15:07:37 GMT
Hi there

If using the JDBC-ODBC bridge then the server executing the JDBC calls MUST
have an ODBC datasource configured on it LOCALLY. On your own PC this is
probably done. Have you done this on your remote Tomcat server??

The ODBC datasource would then have to point to whatever server your
database is running on.

Rory

-----Original Message-----
From: AMRAN121@aol.com [mailto:AMRAN121@aol.com]
Sent: Friday, June 28, 2002 11:00 AM
To: tomcat-user@jakarta.apache.org
Subject: weird connection problems


Hi all
 I currently have MS Access as my backend database and Tomcat as server.
When 
I try to connect to a datasource over the network with the jsp (presentation

purpose) and java bean (business logic (where I establish connection to 
Access database)) setup, i get an error. If I use the same jsp and java bean

to retrieve information from a database which is on my local pc then it is 
able to do it ok. 

Why is this happening? I am using a jdbc:odbc driver (the one that comes
free 
with jdk1.4 (TYPE 1)). I thought it may be the driver but the funny thing is

if I write a jsp (presentation and business logic mixed) to retrieve the
data 
from over the network then it works!!! Has anyone else had this problem?
Does 
anyone know what I could be doing wrong? Any suggestions?

Kind Regards
Amran


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

Mime
View raw message