tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Douglas, Rory" <Rory.Doug...@na.sunchem.com>
Subject RE: auto deploy seems to fail on 4.0.2/win98 and 4.0.1/linux
Date Tue, 04 Jun 2002 13:48:58 GMT
tomcat will only auto deploy war's at startup and then only if a directory
with the same name as the war file does not already exist in your webapps
directory. If you want to update a running web-app, you need to specify a
<context> element for it in conf\server.xml and specify the 'reloadable'
attribute as "true". You can then manually copy updated web app files into
the existing webapp dir and Tomcat will reload the app.

-----Original Message-----
From: Ray Tayek [mailto:rtayek@attbi.com]
Sent: Tuesday, June 04, 2002 5:29 AM
To: tomcat-user@jakarta.apache.org
Subject: auto deploy seems to fail on 4.0.2/win98 and 4.0.1/linux


hi, using tomcat 4.0.2 on win98 and 4.0.1 on slak 8.0. trying to work 
through the examples in Java Tools for Extreme Programming: Mastering Open 
Source Tools: Including Ant, JUnit, and Cactus" by Richard Hightower, 
Nicholas Lesiecki.

all is well until i copy the hello.wat file to tomat/webapps (while it is 
running). i can not get at the servlet from a browser. stopping and 
restarting does not help. the hello.war is not unjared.

anybody got a clue?

thanks

---
ray tayek http://home.attbi.com/~rtayek/ actively seeking telecommuting work
vice chair orange county java users group http://www.ocjug.org/ 
mailto:chair@ocjug.org
hate spam? http://samspade.org/ssw/


--
To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message