tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reynir Hübner <rey...@hugsmidjan.is>
Subject RE: Help Please - trying to get Tomcat to work with IIS
Date Wed, 26 Jun 2002 17:39:43 GMT
ok

1. Is the arrow green (pointing upwards) ?
really the only reason for it pointing downwards (and being red) is that the registry info
is not correct (really just not pointing correctly to the files).
to see if it's working you can set the log_level to debug (in the registry). 

2. If the arrow is green you need to create a virtual directory called /jakarta/ and this
directory must have the isapi_redirect.dll in it, the same one as installed as isapi_filter.

3. create the following in server.xml : 
 <Connector className="org.apache.ajp.tomcat4.Ajp13Connector" 
  port="8009"
  minProcessors="5" 
  maxProcessors="75" 
  acceptCount="10" 
  debug="9"/>

4. if you're workers.properties and uriworkermap.properties is correctly set up then this
should work. 

attached are my props files :) throw me a line if this doesn't work.


hope it helps.
-reynir@hugsmidjan.is









> -----Original Message-----
> From: David Thielen [mailto:dave@thielen.com]
> Sent: 26. júní 2002 17:34
> To: tomcat-user@jakarta.apache.org
> Subject: Help Please - trying to get Tomcat to work with IIS
> 
> 
> Hi;
> 
> I've been fighting this for 24 hours now and I feel so close 
> - yet not there.
> 
> My system uses IIS and I just added Tomcat 4.0 release 
> (downloaded yesterday). I have followed all of the 
> instructions for connecting Tomcat to IIS including using a 
> workers.properties, uriworkermap.properties, and server.xml 
> provided by someone who has Tomcat working with IIS.
> 
> >From a browser on another system, I can access .jsp's that 
> are under the tomcat/webapps directory and they display 
> correctly. But I cannot access .jsp's that are under 
> c:\InetPub\wwwroot. I get two kinds of problems.
> 
> 1) If I access the default web site I get:
> 
> Apache Tomcat/4.0.4 - HTTP Status 404 - /store/10.jsp
> 
> --------------------------------------------------------------
> ------------------
> 
> type Status report
> 
> message /store/10.jsp
> 
> description The requested resource (/store/10.jsp) is not available.
> 
> 
> 
> 2) I I access via a virtual website I get:
> 
> HTTP 404 - File not found (the message is from IIS)
> 
> 
> Any ideas?
> 
> help - thanks - dave
> 

Mime
View raw message