tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turner, John" <JTur...@AAS.com>
Subject RE: 4.1.3 Beta & mod_jk2 ALMOST working
Date Fri, 21 Jun 2002 16:48:59 GMT

According to this thread, there seems to be a problem with mod_jk and the
latest apache (2.0.39):

http://mailman.real-time.com/pipermail/tomcat-users/2002-June/069534.html

John Turner
jturner@aas.com
http://www.aas.com


-----Original Message-----
From: Douglas, Rory [mailto:Rory.Douglas@na.sunchem.com]
Sent: Friday, June 21, 2002 12:11 PM
To: Tomcat Users List (E-mail)
Subject: 4.1.3 Beta & mod_jk2 ALMOST working


Hi there 
I'm trying Apache 2.0.39 and Tomcat 4.1.3 Beta on a Win2K machine with
mod_jk2 nightly binary. 
I'm doing all my configuration through workers2.properties (copied from
jtc-src in the 4.1.3 download). My Coyote JK2 connector is on the default
port 8009 and Apache2 is on port 9000.
It's almost working (I think).  I can start Apache with no errors. My
Apache2 error log registers: 
    
  [warn] workerEnv.init() ok C:/Dev/Apache2/conf/workers2.properties 
  [warn] mod_jk child init 1 -1 
which seems good.  I can then browse localhost:9000/jkstatus and see a JK2
status page. 
However, if I try to browse localhost:9000/examples (I have
[uri:/examples/*] set up) then I get 500 error from Apache.  The log shows:
  [warn] service.init() Can't find child in scoreboard 2208 
  [error] channelSocket.connect() connect failed dlportaldevsys1:8009 61
Unknown error 
  [error] ajp13.connect() failed ajp13:dlportaldevsys1:8009 
  [error] ajp13.service() failed to connect endpoint errno=61 Unknown error 
  [warn] ajp13.done() close endpoint ajp13:dlportaldevsys1:8009 error_state
1 
  [error] mod_jk.handler() Error connecting to tomcat 21000 
The first line doesn't seem too serious, but line two's "connect failed...61
Unknown error" is puzzling. I definitely have a connector configured on
8009, and I believe I've set the right className and
protocolHandlerClassName attributes as well (see shortened version below).
  <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
      port="8009" 
      protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler" 
      useURIValidationHack="false"> 
    <Factory 
      className="org.apache.catalina.net.DefaultServerSocketFactory"/> 
  </Connector> 


Does anyone know what Error 61 is? Any help would be most appreciated. This
is the closest I've come to getting Apache2/Tomcat4/mod_jk to work on Win2K.
I suspect perhaps my jk2.properties file is incorrect. By default
"channelSocket.port=8019" is there, changing to 8009 gives me different
errors, namely "Bad file descriptor", "BAD MESSAGE" etc.
Thanks & apologies for the long, code-ridden mail 
Rory Douglas 
Sun Chemical Corporation 
(201) 224-4600 x133 
rory.douglas@na.sunchem.com 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message