tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Turner, John" <>
Subject RE: Trouble Compiling mod_webapp
Date Thu, 13 Jun 2002 15:09:06 GMT

I got the same error last week.  I fixed it by getting and installing APR
from CVS according to the mod_webapp README.txt.

Also make sure that the apxs your install is finding is the Apache 2
apxs...if this is a machine that also has Apache 1.x, the buildconf script
may be picking up the Apache 1.x apxs instead of the Apache 2 apxs.  You can
explicitly declare which apxs to use.

John Turner

-----Original Message-----
From: Bruce Wright []
Sent: Thursday, June 13, 2002 4:44 AM
Subject: Trouble Compiling mod_webapp

I have apache 2.0.36 compiled and installed on RedHat 7.3

I'm using the following two source archives:

Step 1.
/bin/sh ./support/
output looks fine...
Creating configure ...
--- All done

Step 2.
./configure --with-apxs=/usr/local/apache2/bin/apxs
output looks fine...till here...

APR location
checking for APR sources...
checking for APR libraries... no
checking for APR includes... no
<--Does this mean I copied the apr to the wrong location?-->

more OK output...
All done. Now you can issue "make". Good luck.

Step 3.
output looks fine...till the end...
ort/ /bin/sh: bad interpreter: Permission denied
make[2]: ***
/libwebapp.a] Error 126
make[2]: Leaving directory
make[1]: Exiting directory "lib"
make[1]: *** [template] Error 2
make[1]: Leaving directory
make: *** [lib-build] Error 2

I am running this as root...why do I get Permission denied???  Any

Thanks in advance

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message