tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re[2]: 4.1.3 Beta & mod_jk2 ALMOST working
Date Fri, 21 Jun 2002 17:03:49 GMT
Hello John,

That isn't an issue anymore.  The nightly binaries were rebuilt.
However, that only includes mod_jk2, not mod_jk.  The fact that Rory
got Apache running at all means he was using a binary compatible with
Apache 2.0.39.

Now if someone can provide a configuration example for how mod_jk2
works!

Jake

Friday, June 21, 2002, 11:48:59 AM, you wrote:


TJ> According to this thread, there seems to be a problem with mod_jk and the
TJ> latest apache (2.0.39):

TJ> http://mailman.real-time.com/pipermail/tomcat-users/2002-June/069534.html

TJ> John Turner
TJ> jturner@aas.com
TJ> http://www.aas.com


TJ> -----Original Message-----
TJ> From: Douglas, Rory [mailto:Rory.Douglas@na.sunchem.com]
TJ> Sent: Friday, June 21, 2002 12:11 PM
TJ> To: Tomcat Users List (E-mail)
TJ> Subject: 4.1.3 Beta & mod_jk2 ALMOST working


TJ> Hi there 
TJ> I'm trying Apache 2.0.39 and Tomcat 4.1.3 Beta on a Win2K machine with
TJ> mod_jk2 nightly binary. 
TJ> I'm doing all my configuration through workers2.properties (copied from
TJ> jtc-src in the 4.1.3 download). My Coyote JK2 connector is on the default
TJ> port 8009 and Apache2 is on port 9000.
TJ> It's almost working (I think).  I can start Apache with no errors. My
TJ> Apache2 error log registers: 
    
TJ>   [warn] workerEnv.init() ok C:/Dev/Apache2/conf/workers2.properties 
TJ>   [warn] mod_jk child init 1 -1 
TJ> which seems good.  I can then browse localhost:9000/jkstatus and see a JK2
TJ> status page. 
TJ> However, if I try to browse localhost:9000/examples (I have
TJ> [uri:/examples/*] set up) then I get 500 error from Apache.  The log shows:
TJ>   [warn] service.init() Can't find child in scoreboard 2208 
TJ>   [error] channelSocket.connect() connect failed dlportaldevsys1:8009 61
TJ> Unknown error 
TJ>   [error] ajp13.connect() failed ajp13:dlportaldevsys1:8009 
TJ>   [error] ajp13.service() failed to connect endpoint errno=61 Unknown error 
TJ>   [warn] ajp13.done() close endpoint ajp13:dlportaldevsys1:8009 error_state
TJ> 1 
TJ>   [error] mod_jk.handler() Error connecting to tomcat 21000 
TJ> The first line doesn't seem too serious, but line two's "connect failed...61
TJ> Unknown error" is puzzling. I definitely have a connector configured on
TJ> 8009, and I believe I've set the right className and
TJ> protocolHandlerClassName attributes as well (see shortened version below).
TJ>   <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
TJ>       port="8009" 
TJ>       protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler" 
TJ>       useURIValidationHack="false"> 
TJ>     <Factory 
TJ>       className="org.apache.catalina.net.DefaultServerSocketFactory"/> 
TJ>   </Connector> 


TJ> Does anyone know what Error 61 is? Any help would be most appreciated. This
TJ> is the closest I've come to getting Apache2/Tomcat4/mod_jk to work on Win2K.
TJ> I suspect perhaps my jk2.properties file is incorrect. By default
TJ> "channelSocket.port=8019" is there, changing to 8009 gives me different
TJ> errors, namely "Bad file descriptor", "BAD MESSAGE" etc.
TJ> Thanks & apologies for the long, code-ridden mail 
TJ> Rory Douglas 
TJ> Sun Chemical Corporation 
TJ> (201) 224-4600 x133 
TJ> rory.douglas@na.sunchem.com 



-- 
Best regards,
 Jacob                            mailto:hoju@visi.com


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message