tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Liam Morley <lmor...@gdc.wpi.edu>
Subject Re: TC 4.1.3: JK2 connector dies?
Date Fri, 28 Jun 2002 01:21:00 GMT
  Ignacio,
thanks for the response. glad to be testing:)

>No idea where comens from this port=8019.., get 4.1.6 ( from CVS or wait
>until Remy packages it ) it may be solves this and much of the other
>problems..
>
thanks, I'll try that when the package comes out.

>>Of course I can set the log level higher to avoid these messages, but 
>>what am I supposed to be warned about?
>>    
>>
>nothing? ;)
>
good to know:)

>Wel you have problems connecting to 8019 port, in the stderr.log says
>what port you are using actually..
>
for what I posted in the last email, everything (I think) was set up to 
use port 8019. stderr.log and stdout.log are attached. I tried running 
in console, and I got a lot more messages that way- I don't remember how 
to set log level on stderr/out.log, so I'm including an attachment of 
the output as well. When running in console, one thing that I noticed 
was this:
[Thu Jun 27 20:57:39 2002] (error ) [jk_config_file.c (261)]  
config.update(): Can't find config file 
${serverRoot}/conf/workers2.properties
[Thu Jun 27 20:57:39 2002] ( info ) [jk_config.c (246)]  
config.setAttribute() Error setting config: file 
${serverRoot}/conf/workers2.properties
[Thu Jun 27 20:57:39 2002] (error ) [jk_logger_file.c (171)]  
Initializing log file stderr
[Thu Jun 27 20:57:39 2002] (error ) [jk_shm.c (333)]  shm.init(): No file
[Thu Jun 27 20:57:39 2002] ( info ) [jk_workerEnv.c (403)]  
workerEnv.init() ok ${serverRoot}/conf/workers2.properties
how is serverRoot specified, and where is it asked for? (I tried 
removing it from workers2.properties, and I still got that message.) I 
tried setting it in both workers2.properties and jk2.properties, neither 
had an effect. Should I be getting a message that says "workerEnv.init() 
ok ...workers2.properties" if config.setAttribute() just had an error 
setting workers2.properties? Also, no matter where I put jk2.shm, I get 
the message "shm.init(): No file".

>You need to put jkjni.dll in your path..
>
Ah, I see. I had jkjni.dll in my APACHE_HOME/modules/ directory.. after 
moving it into my WINDOWS directory (along with libapr.dll and 
libaprutil.dll), I'm not seeing that message anymore, so that looks all 
set. Are there any other dlls that should be in my path instead of in my 
modules folder?

Thanks again for the help.
Liam Morley

Mime
View raw message