tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Wilson <web...@yahoo.com>
Subject Re: newbie question.
Date Thu, 20 Jun 2002 14:30:12 GMT
Look at the seventh line of your sever.xml file,
change it to 8080 from 8008, or to whatever you are
calling tomcat from.  You can set this to whatever you
want.

--- chad kellerman <ckellerman@alabanza.com> wrote:
> The way I have configure the server.xml file tomcat
> does not ananswer on 8080 
> through http.
> 
> <snip>
> 
> <Server port="8005" shutdown="SHUTDOWN" debug="0">
>     <!-- define an Apache-Connector Service for
> unsecured sites-->
>     <Service name="Apache">
>         <!-- the connector for unsecure traffic -->
>         <Connector className = 
> "org.apache.catalina.connector.warp.WarpConnector"
>           port="8008"
>           minProcessors="2"
>           maxProcessors="10"
>           scheme="http"
>           secure="false"
>           enableLookups="true"
>           appBase="webapps"
>           acceptCount="10"
>           debug="0"/>
> 
>                 <!-- testing reloadable servlets -->
>                 <DefaultContext reloadable="true"/>
>                 <!-- it's all about the warp engine
> -->
>                 <Engine className = 
> "org.apache.catalina.connector.warp.WarpEngine"
>                      name="Apache"
>                      debug="0">
> 
>                 <Logger className =
> "org.apache.catalina.logger.FileLogger"
>                   directory="/var/log/tomcat"
>                   prefix="file-log"
>                   timestamp="true"/>
> 
>                 <Realm className =
> "org.apache.catalina.realm.MemoryRealm"/>
> 
> 
>                         <!-- define all non-secure
> virtual hosts below -->
> 
> </snip>
> 
> 
> 
> I have been doing more research on this.  I think
> this is where I am getting 
> lost.
> 
> 
>       The servlet is in my webapp directory.
> Do I need to create a /WEB_INF/ directory with a
> web.xml file in there for 
> servlet mapping?  Or should the servlet just wor?
> 
> --chad
> 
> 
> 
> On Thu June 20 2002 8:46 am,
> Brendan.Richards@lowelive.com wrote:
> > This isn't clear from your email:
> >
> > Can you run the servlet by going to Tomcat
> directly (port 8080 by default)
> > rather than through the webapp connector?
> >
> >
> > ----------------------------------------------
> >
> >
> > Good day to everyone,
> >
> >    I have a bit of a newbie questions.  I am using
> Red HAt 6.2 tomcat 4.0.3
> > with mod_webapp with Virtual Hosts.
> >
> >    I tried to compile a simple hello world
> servlet.  I did not have the
> > classpath to the servlet.jar file in
> /usr/local/tomcat/common/lib so I had
> > to
> > include that option in my javac line.  ie.
> >
> > javac -classpath /usr/local/tomcat/common/lib
> HelloServlet.java
> >
> >   It compiled with now errors.
> >
> > First question, is there a way I can test to make
> sure this servelet is
> > compiled cor4ectly on the command line?
> >
> >    I am able to pull up all jsp pages that I have
> written correctly in my
> > webapps directory.  (Virtual Host)
> >
> >    But when I try to call up my HelloServlet I get
> a http status 404 error
> > The funny thing is that the age has html source in
> it.  It does not show as
> > a
> > web page but  but as one line html code.
> >
> >     My httpd.conf looks like this:
> >
> > <VirtualHost test-domain.com>
> > User test
> > Group test-domaingrp
> > ServerName test-domain.com
> > ServerAdmin webmaster@test-domain.com
> > DocumentRoot /home/test/test-domain-www
> > TransferLog /home/test/test-domain-logs/access-log
> > ScriptAlias /cgi-bin/
> /home/test/test-domain-www/cgi-bin/
> > WebAppConnection conn1 warp localhost:8008
> > WebAppDeploy .   conn1    webapps
> > WebAppDeploy test.war  conn1    webapps/gotc
> > </VirtualHost>
> >
> > and my server.xml for the virtual hosts file looks
> like this:
> >
> > <!-- define all non-secure virtual hosts below -->
> >                         <Host className =
> > "org.apache.catalina.connector.warp.WarpHost"
> >                          
> name="tomcat-test.gotc.net"
> >                           debug="0"
> >                          
> appBase="/home/gotc/tomcat-test-www/webapps"
> >                           unpackWARs="false" >
> >
> >                              <Valve
> >
>
className="org.apache.catalina.valves.AccessLogValve"
> >                                
> directory="/home/gotc/tomcat-test-logs"
> >                                
> prefix="access-log"
> >                                 pattern="common"/>
> >
> >                              <Context
> path="manager" docBase="manager"
> > debug="0" privileged="true"/>
> >                              <Context
> path="webapps" docBase="webapps"
> > debug="0" reloadable="true"/>
> >                         </Host>
> >
> >
> >
> >   I thought if I put WebAppDeploy .   conn1   
> webapps in my Virtual Host
> > section I could call anything from my webapps
> directory.
> >
> > I guess I am wrong.
> >
> > Is there anyone that can help me??
> >
> > Thanks you in advance.
> >
> > --chad
> 
> -- 
> Chad Kellerman
> Alabanza Inc.
> Jr. Systems Administrator
> 10 E. Baltimore Street
> Baltimore, Md 21202
> 
> --
> To unsubscribe, e-mail:  
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
> 


__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message