tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Eric Miller" <jemil...@uchicago.edu>
Subject Re: Authentication
Date Mon, 17 Jun 2002 21:42:21 GMT
Um, I think it might have something to do with the fact that you have the
userPassword attribute set to cn.

Jon

----- Original Message -----
From: "Josh Fenlason" <jfenlason@ptc.com>
To: "Tomcat" <tomcat-user@jakarta.apache.org>
Sent: Monday, June 17, 2002 1:49 PM
Subject: Authentication


> I'm trying to authenticate with Tomcat4.1.3 but not having much success.
> Using the <Realm/> below I can authenticate when the user name and
password
> are the same, e.g. username=foo password=foo.  However, if the username
and
> password are not the same, e.g. username=foo password=bar.  Also, if the
> username and password are different, e.g. username=foo password=bar, it
> won't authenticate if you enter the username=foo password=bar.  So it must
> be connecting to the ldap directory and checking the password, right?  I
am
> thoroughly stumped.  If anyone has any ideas, I would greatly appreciate
it.
> Thanks in advance.
> ,
> Josh.
>
> <Realm className="org.apache.catalina.realm.JNDIRealm"
>     connectionURL="ldap://camaro.mn.ptc.com:389"
>     roleName="cn"
>     roleBase="ou=People,ou=jfenlason_r62DC,ou=jfenlason,l=Arden
Hills,o=PTC"
>     roleSearch="(uniqueMember={0})"
>     userPassword="cn"
>     userPattern="uid={0},ou=People,ou=jfenlason_r62DC,ou=jfenlason,l=Arden
> Hills,o=PTC"
>     roleSubtree="true"
>     debug="99"/>
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message