tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "fva" <ee2_l...@maxiq.ro>
Subject Re: Connection to Oracle database doesn't work when Tomcat is a service
Date Thu, 27 Jun 2002 16:48:52 GMT
User SYSTEM is not allowed (normally) to make network connections to the
outside world out of its own initiative.
This is my suggestion:

Create another user for the Tomcat service.
Make it a plain one.
Logon interactively and test Tomcat from command line.
Grant any additional privileges needed until Tomcat runs fnie from command
line and DB connection is OK.
You might have to add some elements to the path.
Add the "Run as a batch job" right (or something like that) to the user.
Edit Tomcat service properties and make it run under that user authority
(instead of default SYSTEM).

I guess that this should be the (approximate) path to solve your problem.

HTH,
Florin

----- Original Message -----
From: "Luciano Belotto" <luciano@traxsoftware.com>
To: "'Tomcat Users List'" <tomcat-user@jakarta.apache.org>
Sent: Thursday, June 27, 2002 07:34
Subject: RE: Connection to Oracle database doesn't work when Tomcat is a
service


> I see. Is there anyone who knows how this should be setup (Oracle
> authentication for System)? Or has had to set this up in order for
> Tomcat to run as a service and connect to database? maybe this questions
> is more appropriate in an Oracle forum
>
> -Luciano
>
> >
> > When the service runs, it does not run under the same
> > permission authority as it does when you execute startup.bat.
> >  I'm not familiar with Oracle authentication, but it sounds
> > like the user that the service runs under (normally System)
> > doesn't have permission to make the connection.
> >
> > John Turner
> > jturner@NOSPAM.aas.com
> >
> >
> > -----Original Message-----
> > From: Luciano Belotto [mailto:luciano@traxsoftware.com]
> > Sent: Thursday, June 27, 2002 11:02 AM
> > To: 'Tomcat Users List'
> > Cc: 'Ramon Lewis'
> > Subject: Connection to Oracle database doesn't work when
> > Tomcat is a service
> >
> >
> > I'm new to this list and to using Tomcat. Request help with this:
> >
> > I setup TomCat 4 with my IIS 5.0 using the instructions on
> http://members.ozemail.com.au/~lampante/howto/tomcat/iisnt/index.html
>
> For the most part everything works fine. My webpage traxusers.com still
> works with IIS (iis runs the html) and TomCat runs the jsp pages I want.
>
> the problem lies in running a jsp that connects to the database, but
> only when I run Tomcat as a service.
>
> If I run TomCat from the startup.bat, everything seems to go fine.
>
> But when i have it running only as a service (setup with the
> jk_nt_service.exe), the JSP pages themselves work fine, but the
> connection to the database returns this error: java.sql.SQLException:
> ORA-12640: Authentication adapter initialization failed
>
> Can anyone suggest/help on this, what should I look for
>
> -Luciano
>
>
> ------------------------------------------------------------------------
> ----
> --
>
>
>
> --
> To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
>
> --
> To unsubscribe, e-mail:
> <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
> <mailto:tomcat-user-help@jakarta.apache.org>
>
>
> --------------------------------------------------------------------------
----
>
>
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message