tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Gregg" <john.gr...@techarch.com>
Subject jdk 1.4 and Oracle drivers
Date Thu, 06 Jun 2002 21:53:18 GMT
Hi all.

Upon completing my most recent project I switched from jdk 1.3.1 to 1.4.
However now I can't start Tomcat (4.0.1) because it can't find the Oracle
jdbc driver class.  When I first started using Oracle with Tomcat, I renamed
the classes12.zip to classes12.jar.  Now no matter where I put
classes12.jar, I get the same error.  I've tried lib, common/lib,
server/lib, and webapps/<project>/web-inf/lib.  FWIW, I have a servlet that
runs at startup and tries to initialize a db connection pool.  This used to
work just fine and in fact still does with postgresql.jar.  I even tried
unzipping classes12.zip and actually jarring it up.  No luck.  I've traced
the problem in a debugger far enough to know that the StandardClassLoader
that should have classes12.jar in its scope doesn't.  In fact, of all the
stuff under common (classes and lib), it's missing classes12.jar and
jdbc2_0-stdext.jar.  Everything else is there.  I see those 2 jars overlap
somewhat, so I tried removing the latter to no avail.  I don't have any
other Tomcat installations and there aren't any jar files in multiple
locations.  I feel like I know everything about this problem but the answer.

thanks

john


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message