tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Divyank Turakhia" <divyan...@directi.com>
Subject WARP Connector and Contexts
Date Mon, 03 Jun 2002 20:05:29 GMT
I am trying to setup tomcat 4.0.3 and Apache 1.3.24 such that I can
forward all requests coming to Apache for http://www.virttest2.com to
tomcat for all web applications inside the webapps folder

I do not want to use multiple WebAppDeploy directives in my Apache
httpd.conf.

Now the problem is that if i use a "WebAppDeploy . conn /" then the
files inside webapps/ROOT are the only ones being served. I also want
the webapps/examples to also be served when a person goes to
http://www.virttest2.com/examples . In my current setup all requests to
http://www.virttest2.com/examples shows an error "Apache Tomcat/4.0.3 -
HTTP Status 404 - /examples/jsp/". I want to do this without adding a
"WebAppDeploy examples conn /examples" in my httpd.conf . i.e i donot
want to add a WebAppDeploy for every Web Application that is auto
deployed for that particular host.

Is there a way i can do this?

I have included the following in my httpd.conf:

# Load the module

LoadModule webapp_module libexec/mod_webapp.so
AddModule mod_webapp.c

<VirtualHost 192.168.1.93>
        DocumentRoot /domains/www.virttest2.com/web
        ServerName www.virttest2.com
        WebAppConnection conn_www.virttest2.com_http warp localhost:8011
        WebAppDeploy . conn_www.virttest2.com_http /
</VirtualHost>

My server.xml has the below settings:

<!-- The Server JVM -->
<Server port="8010" shutdown="SHUTDOWN" debug="0">
    <!-- Define an Apache-Connector Service for unsecured-->
    <Service name="Domain-Private-HTTP">
        <!-- the connector for non-https traffic -->
        <Connector className =
"org.apache.catalina.connector.warp.WarpConnector"
          port="8011"
          minProcessors="2"
          maxProcessors="10"
          scheme="http"
          secure="false"
          enableLookups="true"
          appBase="webapps"
          acceptCount="10"
          debug="0"/>

        <!-- The WarpEngine in action -->
        <Engine className =
"org.apache.catalina.connector.warp.WarpEngine"
          name="Domain-Private-HTTP"
          debug="0">
        <Logger className = "org.apache.catalina.logger.FileLogger"
          prefix="private_http_log."
          suffix=".txt"
          timestamp="true"/>

            <Realm className = "org.apache.catalina.realm.MemoryRealm"
/>

            <!-- Define the virtual hosts in use -->
            <Host className =
"org.apache.catalina.connector.warp.WarpHost"
              name="virttest2.com"
              debug="0"
              appBase="webapps"
              unpackWARs="true" >

                <Context path="" docBase="ROOT" debug="0"/>

            </Host>

        </Engine>
    </Service>
</Server>


Warm Regards,
Divyank Turakhia


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message