tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Frick" <gjfr...@hotmail.com>
Subject Re: I'm getting no responses to my requests for help on this list
Date Thu, 16 May 2002 16:37:04 GMT
Michael,

   I'm running on Windows XP Professional so your suggested 'list process'
command won't apply.  If I do a c:\netstat -an I get the following:

 TCP    0.0.0.0:8080           0.0.0.0:0              LISTENING

but that doesn't tell me what process is actually doing the listening.

   Is this the section that I need to modify:

    <!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->
    <Connector className="org.apache.catalina.connector.http.HttpConnector"
               port="8080" minProcessors="5" maxProcessors="75"
               enableLookups="true" redirectPort="8443"
               acceptCount="10" debug="0" connectionTimeout="60000"/>


----- Original Message -----
From: "Michael Teter" <michael_teter@yahoo.com>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Thursday, May 16, 2002 10:45 AM
Subject: Re: I'm getting no responses to my requests for help on this list


> This list is very active, and due to the amount of
> noise, it's hard to see or respond to every message.
> I'm sure it's not personal :)
>
> Anyway, I don't know the background on your problem,
> but the "address already in use" issue is certainly
> not going to help anything.
>
> You've got to figure out what you have running that
> could be using that port.  I can't remember which app
> servers use which ports for sure, but almost certainly
> you already have an app server running.  Do a $ ps -ef
> | more and scour the list of processes.  Do you have
> Turbine/tdk?  Zope?  OpenACS/AOLServer?  Anything
> else?
>
> As a last resort, (but I really recommend you find the
> conflict instead), you could edit your
> $TOMCAT_HOME/conf/server.xml file and change your
> non-SSL HTTP connector entry to use a different port,
> like say 8675.  Then create the following file in your
> $TOMCAT_HOME/webapps/ROOT
>
> File test.jsp---------------------------
> <html><head><title>Test</title></head>
> <body>
> <%
> String s = "Hello World.";
> %>
> <h1>This is my test page</h1>
> <%=s%>
> </body>
> </html>
> (end of test.jsp)------------------------
>
> Now point your browser to
> http://127.0.0.1:8675/test.jsp
>
> You should see a page that says
> "This is my test page
>  Hello World."
>
> Good luck.
> Michael
>
>
> --- Gary Frick <gjfrick@hotmail.com> wrote:
> > Hi All,
> >
> >    I've been working day and night trying to get
> > Tomcat started and to get past the HTTP 500 error
> > when trying to invoke the JSP examples.  I've been
> > combing the archives, but I'm not seeing any real
> > solutions.  What must I do and where must I go to
> > get help?
> >
> >    First it would be helpful to know what is going
> > on.  When I try to start Tomcat I get the following
> > (See below. Only providing first few lines of
> > trace).  When I try //localhost/examples  I can
> > execute the servlets, but not the JSPs.  On the JSPs
> > I always get HTTP Status 500 messages.  I've
> > followed the recommendations to recheck the
> > classpaths and environment variables (JAVA_HOME and
> > TOMCAT_HOME), but this hasn't helped.  For one thing
> > I don't understand why port 8080 is already in use.
> > How can I check?
> >
> > Thanks,
> > Gary
> >
> > Catalina.start: LifecycleException:  null.open:
> > java.net.BindException: Address
> >  already in use: JVM_Bind:8080
> > LifecycleException:  null.open:
> > java.net.BindException: Address already in use:
> >  JVM_Bind:8080
> >         at
> >
> org.apache.catalina.connector.http.HttpConnector.initialize(HttpConne
> > ctor.java:1130)
> >         at
> >
> org.apache.catalina.core.StandardService.initialize(StandardService.j
> > ava:454)
> >         at
> >
> org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
> > a:553)
> >         at
> >
> org.apache.catalina.startup.Catalina.start(Catalina.java:780)
> >         at
> >
> org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
> >         at
> >
> org.apache.catalina.startup.Catalina.process(Catalina.java:179)
> >         at
> > sun.reflect.NativeMethodAccessorImpl.invoke0(Native
> > Method)
> >         at
> > sun.reflect.NativeMethodAccessorImpl.invoke(Unknown
> > Source)
> >         at
> >
> sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
> > Source)
> >         at java.lang.reflect.Method.invoke(Unknown
> > Source)
> >         at
> >
> org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)
> > ----- Root Cause -----
> > java.net.BindException: Address already in use:
> > JVM_Bind:8080
> >         at
> >
> org.apache.catalina.connector.http.HttpConnector.open(HttpConnector.j
> > ava:950)
> >
>
>
> __________________________________________________
> Do You Yahoo!?
> LAUNCH - Your Yahoo! Music Experience
> http://launch.yahoo.com
>
> --
> To unsubscribe, e-mail:
<mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands, e-mail:
<mailto:tomcat-user-help@jakarta.apache.org>
>
>

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message