tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rich Downing" <rdown...@custominsurance.com>
Subject IIS 5.0 + TC 4.0.3
Date Fri, 17 May 2002 15:55:56 GMT
As best I can tell I have everything set up right: isapi_redirector.dll,
virtual directory, filter, etc.  However I get the following 404 status
in the iis_redirect.log when using ajp13 even though it sees test.jsp.

[Fri May 17 11:26:01 2002]  [jk_uri_worker_map.c (464)]: Attempting to
map URI '/test.jsp'
[Fri May 17 11:26:01 2002]  [jk_uri_worker_map.c (478)]:
jk_uri_worker_map_t::map_uri_to_worker, Found an exact match ajp13 ->
/test.jsp
[Fri May 17 11:26:01 2002]  [jk_isapi_plugin.c (721)]: HttpFilterProc
[/test.jsp] is a servlet url - should redirect to ajp13
[Fri May 17 11:26:01 2002]  [jk_isapi_plugin.c (784)]: HttpFilterProc
check if [/test.jsp] is points to the web-inf directory
[Fri May 17 11:26:01 2002]  [jk_isapi_plugin.c (824)]: HttpExtensionProc
started
[Fri May 17 11:26:01 2002]  [jk_worker.c (132)]: Into
wc_get_worker_for_name ajp13
[Fri May 17 11:26:01 2002]  [jk_worker.c (136)]: wc_get_worker_for_name,
done  found a worker
[Fri May 17 11:26:01 2002]  [jk_isapi_plugin.c (860)]: HttpExtensionProc
got a worker for name ajp13
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (1352)]: Into
jk_worker_t::get_endpoint
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (1075)]: Into
jk_endpoint_t::service
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (280)]: Into
ajp_marshal_into_msgb
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (413)]:
ajp_marshal_into_msgb - Done
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (612)]: sending to ajp13
#496
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (853)]: ajp_send_request 2:
request body to send 0 - request body to resend 0
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (698)]: received from ajp13
#17
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (461)]:
ajp_unmarshal_response: status = 404
[Fri May 17 11:26:01 2002]  [jk_ajp_common.c (466)]:
ajp_unmarshal_response: Number of headers is = 0
[Fri May 17 11:26:01 2002]  [jk_isapi_plugin.c (428)]: Into
jk_ws_service_t::start_response
[Fri May 17 11:26:02 2002]  [jk_ajp_common.c (698)]: received from ajp13
#604
[Fri May 17 11:26:02 2002]  [jk_isapi_plugin.c (562)]: Into
jk_ws_service_t::write
[Fri May 17 11:26:02 2002]  [jk_ajp_common.c (698)]: received from ajp13
#2
[Fri May 17 11:26:02 2002]  [jk_isapi_plugin.c (872)]: HttpExtensionProc
service() returned OK
[Fri May 17 11:26:02 2002]  [jk_ajp_common.c (1307)]: Into
jk_endpoint_t::done

localhost_access_log.2002.05.17.txt shows the following:
192.168.1.30 -  [17/May/2002:11:26:01 -0500] "GET /test.jsp HTTP/1.1"
404 600


When attempting to use ajp12 instead, I get the following failure on the
socket connection.

[Fri May 17 11:42:58 2002]  [jk_uri_worker_map.c (464)]: Attempting to
map URI '/test.jsp'
[Fri May 17 11:42:58 2002]  [jk_uri_worker_map.c (478)]:
jk_uri_worker_map_t::map_uri_to_worker, Found an exact match ajp12 ->
/test.jsp
[Fri May 17 11:42:58 2002]  [jk_isapi_plugin.c (721)]: HttpFilterProc
[/test.jsp] is a servlet url - should redirect to ajp12
[Fri May 17 11:42:58 2002]  [jk_isapi_plugin.c (784)]: HttpFilterProc
check if [/test.jsp] is points to the web-inf directory
[Fri May 17 11:42:58 2002]  [jk_isapi_plugin.c (824)]: HttpExtensionProc
started
[Fri May 17 11:42:58 2002]  [jk_worker.c (132)]: Into
wc_get_worker_for_name ajp12
[Fri May 17 11:42:58 2002]  [jk_worker.c (136)]: wc_get_worker_for_name,
done  found a worker
[Fri May 17 11:42:58 2002]  [jk_isapi_plugin.c (860)]: HttpExtensionProc
got a worker for name ajp12
[Fri May 17 11:42:58 2002]  [jk_ajp12_worker.c (227)]: Into
jk_worker_t::get_endpoint
[Fri May 17 11:42:58 2002]  [jk_ajp12_worker.c (123)]: Into
jk_endpoint_t::service
[Fri May 17 11:42:58 2002]  [jk_connect.c (116)]: Into jk_open_socket
[Fri May 17 11:42:58 2002]  [jk_connect.c (123)]: jk_open_socket, try to
connect socket = 2796
[Fri May 17 11:42:59 2002]  [jk_connect.c (132)]: jk_open_socket, after
connect ret = -1
[Fri May 17 11:42:59 2002]  [jk_connect.c (151)]: jk_open_socket,
connect() failed errno = 61
[Fri May 17 11:42:59 2002]  [jk_ajp12_worker.c (136)]: In
jk_endpoint_t::service, sd = -1
[Fri May 17 11:42:59 2002]  [jk_ajp12_worker.c (154)]: In
jk_endpoint_t::service, Error sd = -1
[Fri May 17 11:42:59 2002]  [jk_isapi_plugin.c (875)]: HttpExtensionProc
error, service() failed
[Fri May 17 11:42:59 2002]  [jk_ajp12_worker.c (165)]: Into
jk_endpoint_t::done
with no entry placed into localhost_access_log.2002.05.17.txt 
Would appreciate any clues.  I have been fighting this thing for over a
week.  I DO have it working on Tomcat-3.3.1, but can't seem to get
anywhere on Tomcat-4.0.3.
Thanks much.
Rich Downing



--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message