tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Sanwald <psanw...@dcn.com>
Subject Mod Webapp?
Date Thu, 23 May 2002 14:48:53 GMT
Hey,
   since I couldn't find very much info about mod_jk, and was having
problems, I decided to use mod_webapp to connect apache 1.3.23 and tomcat
4.0.3 (on a fresh install of redhat 7.0).

it worked great when I first installed it, then I rebooted the box. tomcat
starts fine, when I try to start apache it says:

[Thu May 23 09:24:49 2002] 5323 (wa_main.c:77) WebApp Library initializing
[Thu May 23 09:24:49 2002] 5323 (wa_main.c:81) Initializing APR
[Thu May 23 09:24:49 2002] 5323 (pr_info.c:66) INFO provider initialized
[Thu May 23 09:24:49 2002] 5323 (pr_warp.c:62) WARP provider initialized
[Thu May 23 09:24:49 2002] 5323 (wa_main.c:101) WebApp Library initialized
Syntax error on line 997 of /opt/apache/conf/httpd.conf:
Cannot get socket address information
./apachectl start: httpd could not be started

the relevant part of my httpd.conf is:

LoadModule webapp_module libexec/mod_webapp.so
WebAppConnection warpConnection warp web5:8008
WebAppDeploy examples warpConnection /examples

does anyone have any idea what the problem might be? what I am confused
about is (as with mod_jk), the connector worked fine until I rebooted the
box. Unfortunately , the error string I'm getting "Cannot get socket address
information" turns up 0 hits on a usenet search, so I have no idea what the
problem may be. 

has anyone even ever tried to get apache/tomcat4 working on redhat 7? I have
asked a couple of questions on this list before and didn't get any
responses. 
anyways, thanks in advance for any help/thoughts you may have. 

--paul 

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message