tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From steven shingler <ste...@hiredminds.com>
Subject Re: Getting tomcat to serve off port 80 on my own servlets
Date Sun, 05 May 2002 19:16:11 GMT

Hi Abraham
Thanks for replying
Is that the Connector directive inside the Tomcat-Standalone Service, or the
Tomcat-Apache one??
I tried setting the port=80 inside the standalone connector - but that then
ceased to work on either port!
This is the error I get on the web page:

WebApp: Error 500
(File: pr_warp.c Line: 271)
Cannot open connection warpConnection


Here's what I have for the tomcat-apache:

<Service name="Tomcat-Apache">

    <Connector className="org.apache.catalina.connector.warp.WarpConnector"
     port="8008" minProcessors="5" maxProcessors="75"
     enableLookups="true"
     acceptCount="10" debug="0"/>

    <!-- Replace "localhost" with what your Apache "ServerName" is set to
-->
    <Engine className="org.apache.catalina.connector.warp.WarpEngine"
     name="Apache" debug="0" appBase="webapps">

      <!-- Global logger unless overridden at lower levels -->
      <Logger className="org.apache.catalina.logger.FileLogger"
              prefix="apache_log." suffix=".txt"
              timestamp="true"/>

      <!-- Because this Realm is here, an instance will be shared globally
-->
      <Realm className="org.apache.catalina.realm.MemoryRealm" />

    </Engine>

  </Service>

Any more help very gratefully received
Thanks
Steven


On 5/5/02 4:32 am, "Abraham Fathman" <afathman@one.net> wrote:

> Steven,
> 
> What does your server.xml say? Particularly the
> 
>   <Connector
> className="org.apache.catalina.connector.http.HttpConnector"
>              port="80" minProcessors="5" maxProcessors="75"
>              enableLookups="true" redirectPort="8443"
>              acceptCount="10" debug="0" connectionTimeout="60000"/>
> 
> Section? See mine above - it just serves on port 80...
> 
> -----Original Message-----
> From: steven shingler [mailto:steven@hiredminds.com]
> Sent: Saturday, May 04, 2002 3:01 PM
> To: Tomcat Users List
> Subject: Getting tomcat to serve off port 80 on my own servlets
> 
> 
> 
> Hello - wondered if someone had a minute to help me with this
> 
> Am following a tutorial on the apple site:
> http://developer.apple.com/internet/macosx/tomcat1.html
> 
> It mentions about serving off port 80 as well as 8080 - and indeed I can
> get the tomcat examples to do this - but my own web-app - called 'mine'
> only serves off 8080
> 
> I can't seem to find a difference in the conf/server.xml or
> mine/WEB-INF/web.xml
> 
> The error message in
> Apache_log
> States:
> [org.apache.catalina.connector.warp.WarpConnector] Error accepting
> requests
> 
> Any pointers very gratefully received
> Many Thanks
> Steven Shingler
> 
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 
> 
> 
> --
> To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
> Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>
> 
> 
> 

Steven Shingler


--
To unsubscribe:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands: <mailto:tomcat-user-help@jakarta.apache.org>
Troubles with the list: <mailto:tomcat-user-owner@jakarta.apache.org>


Mime
View raw message