tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jules Beeston <jules.bees...@ihavemoved.com>
Subject mod_jk for Apache 2.0, Tomcat 4.0.1 on Linux
Date Fri, 10 May 2002 08:27:33 GMT
Hi,

I've looked for a binary version of mod_jk for tomcat 4.0.1 & Apache 2 for
Linux at jakarta.apache.org but none yet exist.

I have tried building a version of mod_jk using the ant build script in
jakarta-tomcat-connectors-4.0.2-01-src.tar.gz, but this requires a build of
tomcat 4.0.x to exist on the machine (for linking).

We are using JBoss-2.4.4_Tomcat-4.0.1 provided by JBoss, so we don't have a
build of tomcat, so I tried building my own installation of tomcat
(jakarta-tomcat-4.0.1-src) but could not due to it requiring 'Java API for
XML Processing (JAXP), version 1.1 or later', I could only get 1.2 which
does not contain crimson.jar nor jaxp.jar (jaxp-api.jar). When I tried
building it the error returned was: "java.lang.NoClassDefFoundError:
org/w3c/dom/traversal/NodeIterator" which does exist in jaxp 1.2 (in
dom.jar), but I don't know how to add it to the build.xml.

Next I tried to build mod_jk with:

	apxs -o mod_jk.so -I../jk -I/usr/local/jdk/include
-I/usr/local/jdk/include/linux -c *.c ../jk/*.c

but this produced linking errors as well. I tried this in the
jakarta-tomcat-connectors-4.0.2-01-src/jk/native/apache-2.0 as well as
jakarta-tomcat-connectors-4.0.2-01-src/jk/native2, including the relevant
jdk includes.

Can anyone tell me what I'm doing wrong? I believe that apache 2.0 requires
different mod_jk.c code which is what I would have thought lived in
jakarta-tomcat-connectors-4.0.2-01-src/jk/native/apache-2.0.

Any ideas?

cheers
Jules

--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message