tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Error when running jsp.
Date Wed, 15 May 2002 12:45:54 GMT

Most likely, you have XML or DOM libraries in your webapp.  They are not 
allowed there according to the Sun classloading spec and, beginning with 
Tomcat 4.0.2, this is enforced by Tomcat.  They must be in the parent 
classloader in $TOMCAT_HOME/lib or $TOMCAT_HOME/common/lib or as part of 
the JDK (in 1.4) or in the $JAVA_HOME/jre/lib/endorsed directory (also 1.4).

Jake

At 10:00 AM 5/15/2002 +0200, you wrote:
>Hi,
>I'm working on tomcat 4.0.3.
>I can run simple jsp .
>But when I run Jsp which use Dom or Sax Api,  Tomcat can't print the
>result, I have always the same error :
>
>Exception report
>Internal Server Error
>javax.servlet.ServletException: org/w3c/dom/range/Range
>
>What precautions must I care?
>Need some help...
>Thanks
>Jc
>
>
>
>
>
>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message