tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Eustace <alan.eust...@dit.ie>
Subject Re: I'm getting no responses to my requests for help on this list
Date Thu, 16 May 2002 16:34:42 GMT
sorry, just noticed- you are running IIS, which (last time i saw it) runs 
on 8080 by default.

you can change your tomcat port easily thus:

open up server.xml (you'll find it at $CATALINA_HOME$/conf)

at line 54 or thereabouts you'll find a port setting- change the port to 
some port in the 8000 region. Here's the section from my machine, with the 
port set to 80(highlighted with ***):

   <!-- Define a non-SSL HTTP/1.1 Connector on port 8080 -->
     <Connector className="org.apache.catalina.connector.http.HttpConnector"
                ***port="80"*** minProcessors="5" maxProcessors="75"
                enableLookups="true" redirectPort="8443"
                acceptCount="10" debug="0" connectionTimeout="60000"/>

At 05:27 PM 5/16/2002 +0100, you wrote:
>simple and dirty, you've probably tried it already-
>fire up a browser with localhost:8080 as the URL (making sure tomcat isn't 
>running) and if IIS or any other server is running, some sort of default 
>page should tell you what the server is.
>
>then you can kill it, (permanently if it's IIS ;))
>a.
>
>
>
>At 12:25 PM 5/16/2002 -0400, you wrote:
>>Tom,
>>
>>I'm just running IIS 5 on XP Professional along with Tomcat.  Does that
>>constitue 2 servers?  If you need to look at any files let me know.
>>
>>Thanks,
>>Gary
>>----- Original Message -----
>>From: "Tom Oinn" <tmo@ebi.ac.uk>
>>To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
>>Sent: Thursday, May 16, 2002 10:33 AM
>>Subject: Re: I'm getting no responses to my requests for help on this list
>>
>>
>> > Hi,
>> >
>> > We're going to need some details of your environment, os and suchlike.
>> > Do you have any other servers running on this machine?
>> >
>> > Tom
>> >
>> > Gary Frick wrote:
>> > >
>> > > Hi All,
>> > >
>> > >    I've been working day and night trying to get Tomcat started and to
>>get past the HTTP 500 error when trying to invoke the JSP examples.  I've
>>been combing the archives, but I'm not seeing any real solutions.  What must
>>I do and where must I go to get help?
>> > >
>> > >    First it would be helpful to know what is going on.  When I try to
>>start Tomcat I get the following (See below. Only providing first few lines
>>of trace).  When I try //localhost/examples  I can execute the servlets, but
>>not the JSPs.  On the JSPs I always get HTTP Status 500 messages.  I've
>>followed the recommendations to recheck the classpaths and environment
>>variables (JAVA_HOME and TOMCAT_HOME), but this hasn't helped.  For one
>>thing I don't understand why port 8080 is already in use.  How can I check?
>> > >
>> > > Thanks,
>> > > Gary
>> > >
>> > > Catalina.start: LifecycleException:  null.open:  java.net.BindException:
>>Address
>> > >  already in use: JVM_Bind:8080
>> > > LifecycleException:  null.open:  java.net.BindException: Address already
>>in use:
>> > >  JVM_Bind:8080
>> > >         at
>>org.apache.catalina.connector.http.HttpConnector.initialize(HttpConne
>> > > ctor.java:1130)
>> > >         at
>>org.apache.catalina.core.StandardService.initialize(StandardService.j
>> > > ava:454)
>> > >         at
>>org.apache.catalina.core.StandardServer.initialize(StandardServer.jav
>> > > a:553)
>> > >         at org.apache.catalina.startup.Catalina.start(Catalina.java:780)
>> > >         at
>>org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
>> > >         at
>>org.apache.catalina.startup.Catalina.process(Catalina.java:179)
>> > >         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> > >         at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
>> > >         at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown
>>Source)
>> > >         at java.lang.reflect.Method.invoke(Unknown Source)
>> > >         at
>>org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)
>> > > ----- Root Cause -----
>> > > java.net.BindException: Address already in use: JVM_Bind:8080
>> > >         at
>>org.apache.catalina.connector.http.HttpConnector.open(HttpConnector.j
>> > > ava:950)
>> >
>> > --
>> > To unsubscribe, e-mail:
>><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>> > For additional commands, e-mail:
>><mailto:tomcat-user-help@jakarta.apache.org>
>> >
>> >
>>
>>--
>>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>>
>>
>>--
>>This message has been scanned for viruses by the
>>DIT Computer Centre Mail Scanner service, and is
>>believed to be clean.
>
>--------------------
>
>Alan Eustace
>CHI Project
>Digital Media Centre
>DIT Aungier Street
>Dublin 2
>
>tel +353 1 402 3264
>fax +353 1 402 3293
>
>
>
>--
>This message has been scanned for viruses by the DIT
>Computer Centre Mail Scanner service, and is
>believed to be clean.
>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>
>
>
>--
>This message has been scanned for viruses by the
>DIT Computer Centre Mail Scanner service, and is
>believed to be clean.

--------------------

Alan Eustace
CHI Project
Digital Media Centre
DIT Aungier Street
Dublin 2

tel +353 1 402 3264
fax +353 1 402 3293



--
This message has been scanned for viruses by the
DIT Computer Centre Mail Scanner service, and is
believed to be clean.


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message