tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Choe <choep...@mindspring.com>
Subject Re: building mod_jk on solaris
Date Fri, 10 May 2002 18:55:26 GMT
thanks for the info.  do you have an idea where i can get it for freebsd 
3.x?  i have tried to compile the mod_jk but i keep getting errors.

At 12:25 PM 5/10/2002, you wrote:
>Subject: Re: building mod_jk on solaris
>From: "Jack Gao" <weigao@hotmail.com>
>  ===
>I think you need mod_jk for freebsd, because mod_jk.so will been loaded by
>Apache, but not Tomcat.
>
>I finally get mod_jk for Apache 2.0 from Tomcat-Connector-4.0.4-b2-src on
>Solaris 7 platform build successfully.
>What I did is: modify apxs under /usr/local/apache2/bin to add a "-shared"
>in link command. Of cause modified build-unix.sh for JAVA_HOME, APACHE_HOME
>and so on also.
>
>The reason I add this in apxs is I can not found any argument for this
>"-shared" for apxs it self, and solaris ld will need this to generate
>mod_jk.so.
>
>Anyway, my mod_jk.so currently works fine on my Solaris 7 box with Apache
>2.0.36 and Tomcat 4.0.3.
>
>Thanks
>
>Jack
>
>"Peter Choe" <choepete@mindspring.com> wrote in message
>news:mailman.1021037040.27374.jakarta_tomcat@basebeans.com...
> > they only seem to have it for sparc.  i am running an intel solaris.
> >
> > if i have apache running on a freebsd machine, and tomcat running on a
> > solaris machine, which mod_jk should i get and where should i place it, on
> > the solaris or the freebsd?
> >
> > thanks.
> >
> > At 09:15 AM 5/10/2002, =?us-ascii?Q?Ion_Larranaga?= wrote:
> >
> > >Hi,
> > >
> > >I think that mod_jk is included within the connectors
> > >package (jakarta-tomcat-connectors-4.0.2-01-src.tar.gz for
> > >instance), so you should try to get it from there.
> > >
> > >Hope it helps,
> > >
> > >   Ion
> > >
> > >-----Mensaje original-----
> > >De: Peter Choe [mailto:choepete@mindspring.com]
> > >Enviado el: viernes, 10 de mayo de 2002 14:53
> > >Para: tomcat-user@jakarta.apache.org
> > >Asunto: building mod_jk on solaris
> > >
> > >
> > >i am trying to build mod_jk for tomcat4.0.  the only mod_jk i found is
> > >actually in tomcat3.3 though.  so, i tried to compile it using the
> > >build-solaris.sh script and i get the following error:
> > >
> > >bash-2.03# ./build-solaris.sh
> > >Building mod_jk
> > >cc -DEAPI -DMOD_PERL -DUSE_EXPAT -O -G -Kpic -I/usr/apache/include
> > >-I../common -I/usr/java/include -I/usr/java/include/solaris -DSOLARIS  -c
> > >../common/jk_ajp12_worker.c
> > >apxs:Break: Command failed with rc=16711680
> > >Error with apxs
> > >
> > >does anyone know how i can fix this?
> > >
> > >
> > >--
> > >To unsubscribe, e-mail:
> > ><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >For additional commands, e-mail:
> > ><mailto:tomcat-user-help@jakarta.apache.org>
> > >
> > >
> > >
> > >--
> > >To unsubscribe, e-mail:
><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > >For additional commands, e-mail:
><mailto:tomcat-user-help@jakarta.apache.org>
> >
> >
> > --
> > To unsubscribe, e-mail:
><mailto:tomcat-user-unsubscribe@jakarta.apache.org>
> > For additional commands, e-mail:
><mailto:tomcat-user-help@jakarta.apache.org>
> >
>
>
>
>--
>To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
>For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


--
To unsubscribe, e-mail:   <mailto:tomcat-user-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:tomcat-user-help@jakarta.apache.org>


Mime
View raw message